aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:11 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit0af7c8b2ecf344b2b1cd819b1b688c45f85a7e9d (patch)
treedefe8bd55d55d91d09b53bb62d1a0f33c6c00fec
parent3cbd22a3eee82b1e4814bcb42ba4699d5ea9d234 (diff)
downloadguix-0af7c8b2ecf344b2b1cd819b1b688c45f85a7e9d.tar
guix-0af7c8b2ecf344b2b1cd819b1b688c45f85a7e9d.tar.gz
gnu: Add ruby-thread-order.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0c8b60ee56..84afa0b1e4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6995,3 +6995,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"Colorize printed text on ANSI terminals")
(home-page "https://github.com/sickill/rainbow")
(license license:expat)))
+
+(define-public ruby-thread-order
+ (package
+ (name "ruby-thread-order")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thread_order" version))
+ (sha256
+ (base32
+ "1n8zs3m7na5jmpf0pw0z79vg0x0lfzajpynp28zb43l89l00qcfi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (description
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (home-page
+ "https://github.com/JoshCheek/thread_order")
+ (license license:expat)))