aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <lichengtai@gmail.com>2021-02-20 22:30:22 -0800
committerLudovic Courtès <ludo@gnu.org>2021-02-22 12:08:30 +0100
commitf500905ce1baf85a2407c5ccde148ee6c2ea2584 (patch)
tree61b4d2a8ff18aab0263955a2ae91516e5ef8a730
parentd70b0f92e975ddf95376ea27f72c136e93b5157f (diff)
downloadguix-f500905ce1baf85a2407c5ccde148ee6c2ea2584.tar
guix-f500905ce1baf85a2407c5ccde148ee6c2ea2584.tar.gz
gnu: Add python-sane.
* gnu/packages/python-xyz.scm (python-sane): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b26fce72a9..ef811054b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -180,6 +180,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages search)
+ #:use-module (gnu packages scanner)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
@@ -23906,3 +23907,25 @@ Application Programming Interface based on the Open Inventor 2.1 API.")
Crayons automatically wraps a given string in the foreground color and
restores the original state after the string is printed.")
(license license:expat)))
+
+(define-public python-sane
+ (package
+ (name "python-sane")
+ (version "2.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "1pi597z94n2mkd821ln52fq0g727n2jxfskf280ip3kf7jw8w294"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (inputs
+ `(("sane-backends" ,sane-backends)))
+ (home-page "https://github.com/python-pillow/Sane")
+ (synopsis "Python interface to the SANE scanner")
+ (description "This package provides Python interface to the SANE scanner
+and frame grabber interface.")
+ (license license:expat)))