aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:58:02 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commitcc67b9e902ed52cd772f98125a09b71cbc5a0c8a (patch)
tree6c618ce14e1c6299020cb2b18ee9db52f6b8720b
parent45561d91b4b2c8323a3f8f5acaee9761793b1d13 (diff)
downloadguix-cc67b9e902ed52cd772f98125a09b71cbc5a0c8a.tar
guix-cc67b9e902ed52cd772f98125a09b71cbc5a0c8a.tar.gz
gnu: Add python-ansicolor.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0c7bd85428..78c5c5cb5a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15641,3 +15641,23 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"A conservative interactive spell checker for source code.")
(license #f)))
+
+(define-public python-ansicolor
+ (package
+ (name "python-ansicolor")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ansicolor" version))
+ (sha256
+ (base32
+ "078zsfx1wchz9l9brp5nz623adydwqxabg4zd4qyszfxp43inzni"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/numerodix/ansicolor")
+ (synopsis
+ "A library to produce ansi color output and colored highlighting and diffing")
+ (description
+ "A library to produce ansi color output and colored highlighting and diffing")
+ (license #f)))