aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:53:00 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:06:13 +0000
commitc97e22985bbbde12b2d35ab0d499e7bfe0711cc4 (patch)
tree26f8146eef18daa3099dff519661a64af8120f4a
parentb7b841250ce2c6a895b6184ba3f55b256e8cc9cd (diff)
downloadguix-c97e22985bbbde12b2d35ab0d499e7bfe0711cc4.tar
guix-c97e22985bbbde12b2d35ab0d499e7bfe0711cc4.tar.gz
gnu: Add python-sybil.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ba8726a307..c1eba3f59b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14998,3 +14998,28 @@ RFC 8265 and RFC 8266.")
(description "Simple decorator to set attributes of target function or
class in a @acronym{DRY, Don't Repeat Yourself} way.")
(license license:expat)))
+
+(define-public python-sybil
+ (package
+ (name "python-sybil")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sybil" version))
+ (sha256
+ (base32
+ "13rdznw3fllmj5sy20bwi3ipzm6rv1dnji1yi01m91ig759jacw6"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(;("python-coveralls" ,python-coveralls)
+ ("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/cjw296/sybil")
+ (synopsis
+ "Automated testing for the examples in your documentation.")
+ (description
+ "Automated testing for the examples in your documentation.")
+ (license license:expat)))