aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:52:29 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:05:49 +0000
commitb7b841250ce2c6a895b6184ba3f55b256e8cc9cd (patch)
tree47675c1fa67c4f9478a7b816b54c78694a3c36dc
parent402c36c1d6299e0d916f4e96ef5bf47efcd4e330 (diff)
downloadguix-b7b841250ce2c6a895b6184ba3f55b256e8cc9cd.tar
guix-b7b841250ce2c6a895b6184ba3f55b256e8cc9cd.tar.gz
Fix python-flake8-polyfill
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9ef0654cb8..ba8726a307 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6051,9 +6051,10 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
(string-append (getcwd) "/build/lib:"
(getenv "PYTHONPATH")))
(zero? (system* "py.test" "-v")))))))
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)))
(native-inputs
- `(("python-flake8" ,python-flake8)
- ("python-mock" ,python-mock)
+ `(("python-mock" ,python-mock)
("python-pep8" ,python-pep8)
("python-pycodestyle" ,python-pycodestyle)
("python-pytest" ,python-pytest)))