aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:58:33 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit7ff64c84113b4600a939e7abbd2a02ef07789de0 (patch)
tree67809eed1a7d19a345c07e4a6f467cbd826495e8
parent8715cd27acbf520ed6c68771d39257dc67adacaf (diff)
downloadguix-7ff64c84113b4600a939e7abbd2a02ef07789de0.tar
guix-7ff64c84113b4600a939e7abbd2a02ef07789de0.tar.gz
gnu: Add python-vulture.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2755dc2912..db4db2a585 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15684,3 +15684,23 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "Lint tool for Vim script Language")
(description "Lint tool for Vim script Language")
(license #f)))
+
+(define-public python-vulture
+ (package
+ (name "python-vulture")
+ (version "0.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vulture" version))
+ (sha256
+ (base32
+ "1884vymmlwnpw2naam5xn3cn7w74sn24yvpkf9n567sb3kkzmc49"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (home-page
+ "https://github.com/jendrikseipp/vulture")
+ (synopsis "Find dead code")
+ (description "Find dead code")
+ (license license:expat)))