aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:53:28 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commit7c264a2a754af1c41088069ddf3afd62baf27217 (patch)
treeae24a2c045967aba5f0ce4bc4b0db86c1bb0b630
parent8be30e7e6c7d0486eed5836ece1c10a9f7e2e581 (diff)
downloadguix-7c264a2a754af1c41088069ddf3afd62baf27217.tar
guix-7c264a2a754af1c41088069ddf3afd62baf27217.tar.gz
gnu: Add python-testfixtures.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7186c348fa..b65447113f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15064,3 +15064,33 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Unified diff parsing/metadata extraction library.")
(license license:expat)))
+
+(define-public python-testfixtures
+ (package
+ (name "python-testfixtures")
+ (version "5.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "testfixtures" version))
+ (sha256
+ (base32
+ "1w581221qbsmc177n7xijqn7wghyaaxxlwd2p34vfcn4jnbfv2ik"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-coverage" ,python-coverage)
+ ;("python-coveralls" ,python-coveralls)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ;("python-pytest-django" ,python-pytest-django)
+ ("python-sybil" ,python-sybil)
+ ("python-zope-component" ,python-zope-component)))
+ (home-page
+ "https://github.com/Simplistix/testfixtures")
+ (synopsis
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (description
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (license license:expat)))