aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:58:48 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit4deb5242ccbd45bedc30e9c41de8e33e4b7ec87b (patch)
treece21df21770a796c7165343242e1e43da2ab0fc2
parent8758a1be3421250ead2f4744a67bc2695d3a8970 (diff)
downloadguix-4deb5242ccbd45bedc30e9c41de8e33e4b7ec87b.tar
guix-4deb5242ccbd45bedc30e9c41de8e33e4b7ec87b.tar.gz
gnu: Add python-yamllint.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8cfe902ad1..d076bc925f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15724,3 +15724,24 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Utility library for gitignore style pattern matching of file paths.")
(license #f)))
+
+(define-public python-yamllint
+ (package
+ (name "python-yamllint")
+ (version "1.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "yamllint" version))
+ (sha256
+ (base32
+ "114nbzy8s9sr9czxx7g64p8naf46zgk2cab0df00l3sz6bmcmkq5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pathspec" ,python-pathspec)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page
+ "https://github.com/adrienverge/yamllint")
+ (synopsis "A linter for YAML files.")
+ (description "A linter for YAML files.")
+ (license #f)))