aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:54:58 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commit2bc91e4d7e26e8560943576bbe6b5cd522413fbf (patch)
tree3d99a33f7f335fac912fb8c63b1f740017ff340c
parentcfee12aaaf86c18e979a960a154a361f7f509723 (diff)
downloadguix-2bc91e4d7e26e8560943576bbe6b5cd522413fbf.tar
guix-2bc91e4d7e26e8560943576bbe6b5cd522413fbf.tar.gz
gnu: Add python-cppclean.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 386804a531..d67693c8c8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15292,3 +15292,22 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Static code checker for CMake files")
(license license:asl2.0)))
+
+(define-public python-cppclean
+ (package
+ (name "python-cppclean")
+ (version "0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cppclean" version))
+ (sha256
+ (base32
+ "05p0qsmrn3zhp33rhdys0ddn8hql6z25sdvbnccqwps8jai5wq2r"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/myint/cppclean")
+ (synopsis
+ "Find problems in C++ source that slow development of large code bases.")
+ (description
+ "Find problems in C++ source that slow development of large code bases.")
+ (license #f)))