aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-17 15:50:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-17 15:53:03 +0200
commitd8fce2362bbd4d35c1b4b7dfb5babdf9a86bc4bb (patch)
treedbdcce1c8b7e00262c4336cabba1959e92a765d1
parentc55beaecd8c5a36052b628cbd429da9ab7803c8d (diff)
downloadguix-d8fce2362bbd4d35c1b4b7dfb5babdf9a86bc4bb.tar
guix-d8fce2362bbd4d35c1b4b7dfb5babdf9a86bc4bb.tar.gz
gnu: Add python-hicmatrix.
* gnu/packages/bioinformatics.scm (python-hicmatrix): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6fcabb6f9e..a2c168b01c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13677,6 +13677,46 @@ storage format, called @code{cool}, used to store genomic interaction data,
such as Hi-C contact matrices.")
(license license:bsd-3)))
+(define-public python-hicmatrix
+ (package
+ (name "python-hicmatrix")
+ (version "12")
+ (source
+ (origin
+ ;; Version 12 is not available on pypi.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deeptools/HiCMatrix.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xhdyx16f3brgxgxybixdi64ki8nbbkq5vk4h9ahi11pzpjfn1pj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* '("requirements.txt"
+ "setup.py")
+ (("cooler *=+ *0.8.5")
+ "cooler==0.8.*"))
+ #t)))))
+ (propagated-inputs
+ `(("python-cooler" ,python-cooler)
+ ("python-intervaltree" ,python-intervaltree)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-scipy" ,python-scipy)
+ ("python-tables" ,python-tables)))
+ (home-page "https://github.com/deeptools/HiCMatrix/")
+ (synopsis "HiCMatrix class for HiCExplorer and pyGenomeTracks")
+ (description
+ "This helper package implements the @code{HiCMatrix} class for
+the HiCExplorer and pyGenomeTracks packages.")
+ (license license:gpl3+)))
+
(define-public python-hicexplorer
(package
(name "python-hicexplorer")