aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-18 22:01:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-18 22:23:51 +0300
commitcac674d99dc4a332e6210c57ec7f1b8164f66642 (patch)
tree7e511eb2c7fde824e3ba8439df5307b9c2b42a12
parent0144f8def8d91a6e0fb2bb83e46bd03569276da4 (diff)
downloadguix-cac674d99dc4a332e6210c57ec7f1b8164f66642.tar
guix-cac674d99dc4a332e6210c57ec7f1b8164f66642.tar.gz
gnu: qrcodegen-cpp: Update to 1.6.0.
* gnu/packages/aidc.scm (qrcodegen-cpp): Update to 1.6.0.
-rw-r--r--gnu/packages/aidc.scm67
1 files changed, 31 insertions, 36 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index b68f2137be..5648f5a9ec 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darringon <jmd@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
@@ -157,39 +157,34 @@ Python as well as GUI widgets for GTK and Qt.")
(license license:lgpl2.1+)))
(define-public qrcodegen-cpp
- ;; Currently this project's installation mechanism only exists as a GitHub
- ;; pull request, so we build from a recent commit that the proposed patch
- ;; applies to.
- (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
- (revision "0"))
- (package
- (name "qrcodegen-cpp")
- (version (git-version "1.5.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nayuki/QR-Code-generator.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (patches (search-patches "qrcodegen-cpp-make-install.patch"))
- (sha256
- (base32
- "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; No ./configure script
- ;; Only build the C++ variant.
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "cpp")
- #t)))))
- (synopsis "QR Code generator library")
- (description "qrcodegen-cpp is a QR code generator library in C++. The
+ (package
+ (name "qrcodegen-cpp")
+ (version "1.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nayuki/QR-Code-generator.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (patches (search-patches "qrcodegen-cpp-make-install.patch"))
+ (sha256
+ (base32
+ "0iq9sv9na0vg996aqrxrjn9rrbiyy7sc9vslw945p3ky22pw3lql"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No ./configure script
+ ;; Only build the C++ variant.
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "cpp")
+ #t)))))
+ (synopsis "QR Code generator library")
+ (description "qrcodegen-cpp is a QR code generator library in C++. The
project also offers Java, Javascript, Python, C, and Rust implementations.")
- (home-page "https://www.nayuki.io/page/qr-code-generator-library")
- (license license:expat))))
+ (home-page "https://www.nayuki.io/page/qr-code-generator-library")
+ (license license:expat)))