aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-13 02:44:21 -0400
committerLudovic Courtès <ludo@gnu.org>2020-04-19 13:27:07 +0200
commita3cbcbaf8b7dcd12a62006bc40a05ead67e10537 (patch)
tree037cd0b67b60991bd3e373d1d17ec6b41e152da0
parent3c91f003416c9fb79af2dc8766a7f449aa03f839 (diff)
downloadguix-a3cbcbaf8b7dcd12a62006bc40a05ead67e10537.tar
guix-a3cbcbaf8b7dcd12a62006bc40a05ead67e10537.tar.gz
gnu: Add notification-daemon.
* gnu/packages/gnome.scm (notification-daemon): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 33aae4545e..3a359abbbb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -250,6 +250,34 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public notification-daemon
+ (package
+ (name "notification-daemon")
+ (version "3.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1rgchqi4j2ll7d6a7lgy7id0w9rrkwkgic1096fbm2zx6n7pc4yx"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("x11" ,libx11)))
+ (synopsis "Notification Daemon for GNOME Desktop")
+ (description "Notification-Daemon is the server implementation of the
+freedesktop.org desktop notification specification.")
+ (home-page "https://wiki.gnome.org/Projects/NotificationDaemon")
+ (license license:gpl2+)))
+
(define-public mm-common
(package
(name "mm-common")