aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-19 21:56:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-20 08:42:05 +0300
commit8c2a6183de5acbd660f219470b03967bf4a1a560 (patch)
tree50e2807f9d863cefac7869557da8152ce91b3140
parent6914eea01dc531ea60925d53ca006bf9f5603a18 (diff)
downloadguix-8c2a6183de5acbd660f219470b03967bf4a1a560.tar
guix-8c2a6183de5acbd660f219470b03967bf4a1a560.tar.gz
gnu: graphene: Update to 1.10.0.
* gnu/packages/gtk.scm (graphene): Update to 1.10.0. [build-system]: Switch to meson-build-system. [arguments]: Update configure-flags to not install tests. [inputs]: Remove python2. Move gobject-introspection ... [native-inputs]: ... to here. Remove autoconf, automake, libtool, which.
-rw-r--r--gnu/packages/gtk.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4882a95eb8..bea4850d15 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Coypright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Patrick Hetu <patrick.hetu@auf.org>
@@ -1711,29 +1711,23 @@ Parcellite and adds bugfixes and features.")
(define-public graphene
(package
(name "graphene")
- (version "1.6.0")
+ (version "1.10.0")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/ebassi/graphene/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/ebassi/graphene/releases/"
+ "download/" version
+ "/graphene-" version ".tar.xz"))
(sha256
- (base32 "1zd2daj7y590wnzn4jw0niyc4fnzgxrcl9i7nwhy8b25ks2hz5wq"))))
- (build-system gnu-build-system)
+ (base32 "16b4hz73bnrgv5v8n96dczkd6xp9qc06lrl43zln3jnl3psrfva0"))))
+ (build-system meson-build-system)
(arguments
- `(#:configure-flags '("--enable-introspection=yes")))
+ `(#:configure-flags '("-Dinstalled_tests=false")))
(native-inputs
- `(("autoconf" ,autoconf)
- ("which" ,which)
- ("pkg-config" ,pkg-config)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("python" ,python)
- ("python-2" ,python-2)
- ("glib" ,glib)
- ("gobject-introspection" ,gobject-introspection)))
+ ("glib" ,glib)))
(home-page "https://ebassi.github.io/graphene/")
(synopsis "Thin layer of graphic data types")
(description "This library provides graphic types and their relative API;