From 8db4e704dc9c6e86c98d7357b85793dea493ff8f Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludovic.courtes@inria.fr>
Date: Tue, 31 Mar 2020 11:06:30 +0200
Subject: gnu: hwloc@2: Skip test that fails on emulated hardware.

Works around <https://bugs.gnu.org/40342>.

* gnu/packages/mpi.scm (hwloc-2)[arguments]: Add
'skip-test-that-fails-on-qemu' phase.
---
 gnu/packages/mpi.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index ec0684168e..3de2f40fda 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -158,6 +158,14 @@ bind processes, and much more.")
                (substitute* "tests/hwloc/linux-libnuma.c"
                  (("numa_available\\(\\)")
                   "-1"))
+               #t))
+           (add-before 'check 'skip-test-that-fails-on-qemu
+             (lambda _
+               ;; Skip test that fails on emulated hardware due to QEMU bug:
+               ;; <https://bugs.gnu.org/40342>.
+               (substitute* "tests/hwloc/hwloc_get_last_cpu_location.c"
+                 (("hwloc_topology_init" all)
+                  (string-append "exit (77);\n" all)))
                #t))))))))
 
 (define-deprecated hwloc-2.0 hwloc-2)
-- 
cgit v1.2.3