summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ssh.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 050ef05f73..79aff945f3 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -184,17 +184,16 @@ a server that supports the SSH-2 protocol.")
(replace 'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
;; install without host keys and system configuration files
- (and (zero? (apply system* "make" "install-nosysconf" make-flags))
- (begin
- (install-file "contrib/ssh-copy-id"
- (string-append (assoc-ref outputs "out")
- "/bin/"))
- (chmod (string-append (assoc-ref outputs "out")
- "/bin/ssh-copy-id") #o555)
- (install-file "contrib/ssh-copy-id.1"
- (string-append (assoc-ref outputs "out")
- "/share/man/man1/"))
- #t)))))))
+ (apply invoke "make" "install-nosysconf" make-flags)
+ (install-file "contrib/ssh-copy-id"
+ (string-append (assoc-ref outputs "out")
+ "/bin/"))
+ (chmod (string-append (assoc-ref outputs "out")
+ "/bin/ssh-copy-id") #o555)
+ (install-file "contrib/ssh-copy-id.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1/"))
+ #t)))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the