aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b6cfbd6e27..2df6631e2a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4602,6 +4602,7 @@ cannot be adequately worked around on the client side of the wire.")
(define-public libxrender
(package
(name "libxrender")
+ (replacement libxrender/fixed)
(version "0.9.9")
(source
(origin
@@ -4626,6 +4627,14 @@ cannot be adequately worked around on the client side of the wire.")
(description "Library for the Render Extension to the X11 protocol.")
(license license:x11)))
+(define libxrender/fixed
+ (package
+ (inherit libxrender)
+ (source (origin
+ (inherit (package-source libxrender))
+ (patches (search-patches
+ "libxrender-CVE-2016-7949.patch"
+ "libxrender-CVE-2016-7950.patch"))))))
(define-public libxtst
(package