summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index fb06196ec4..85bbe7e9c6 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -122,10 +122,10 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
(home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
(define-public vpnc-scripts
- (let ((commit "6f87b0fe7b20d802a0747cc310217920047d58d3"))
+ (let ((commit "07c3518dd6b8dc424e9c3650a62bed994a4dcbe1"))
(package
(name "vpnc-scripts")
- (version (string-append "20161214." (string-take commit 7)))
+ (version (string-append "20180226." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri
@@ -135,7 +135,7 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pa36w4wlyyvfb66cayhans99wsr2j5si2fvfr7ldfm512ajwn8h"))))
+ "02d29nrmnj6kfa889cavqn1pkn9ssb5gyp4lz1v47spwx7abpdi7"))))
(build-system gnu-build-system)
(inputs `(("coreutils" ,coreutils)
("grep" ,grep)
@@ -161,7 +161,7 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
(delete 'configure) ; no configure script
(replace 'build
(lambda _
- (zero? (system* "gcc" "-o" "netunshare" "netunshare.c"))))
+ (invoke "gcc" "-o" "netunshare" "netunshare.c")))
(replace 'install
;; There is no Makefile; manually install the relevant files.
(lambda* (#:key outputs #:allow-other-keys)
@@ -193,7 +193,8 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
"sed"
"which")))))
(find-files (string-append out "/etc/vpnc/vpnc-script")
- "^vpnc-script"))))))
+ "^vpnc-script"))
+ #t))))
#:tests? #f)) ; no tests
(home-page "http://git.infradead.org/users/dwmw2/vpnc-scripts.git")
(synopsis "Network configuration scripts for Cisco VPN clients")