summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm66
1 files changed, 21 insertions, 45 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8850543c1d..23c63fabdb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,6 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages video)
+ #:use-module (ice-9 match)
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ bsd-3 public-domain))
#:use-module (guix packages)
@@ -56,14 +58,14 @@
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "2.3")
+ (version "2.3.1")
(source (origin
(method url-fetch)
(uri (string-append "http://www.ffmpeg.org/releases/ffmpeg-"
version ".tar.bz2"))
(sha256
(base32
- "17l0bx95al6cjhz3pzfcbwg07sbfbwqbxg34zl5lhl89w9jbngbb"))))
+ "10w1sw5c9qjlaqlr77r3znzm7y0y9qpkni0mfr9rhij22562yspf"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -168,31 +170,11 @@
"--enable-libtheora"
"--enable-libvorbis"
"--enable-libvpx"
- ;; drop special machine instructions not supported
- ;; on all instances of the target
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '()
- '("--disable-amd3dnow"
- "--disable-amd3dnowext"
- "--disable-mmx"
- "--disable-mmxext"
- "--disable-sse"
- "--disable-sse2"))
- "--disable-altivec"
- "--disable-sse3"
- "--disable-ssse3"
- "--disable-sse4"
- "--disable-sse42"
- "--disable-avx"
- "--disable-fma4"
- "--disable-avx2"
- "--disable-armv5te"
- "--disable-armv6"
- "--disable-armv6t2"
- "--disable-vfp"
- "--disable-neon"
+
+ "--enable-runtime-cpudetect"
+
+ ;; Runtime cpu detection is not implemented on
+ ;; MIPS, so we disable some features.
"--disable-mips32r2"
"--disable-mipsdspr1"
"--disable-mipsdspr2"
@@ -268,10 +250,6 @@ audio/video codec library.")
(arguments
`(#:configure-flags
`("--disable-a52" ; FIXME: reenable once available
- "--disable-mmx" ; FIXME: may be enabled on x86_64
- "--disable-sse" ; 1-4, no separate options available
- "--disable-neon"
- "--disable-altivec"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")))) ; needed for the tests
@@ -342,20 +320,18 @@ treaming protocols.")
libx11 "/include") ; to detect libx11
"--disable-tremor-internal" ; forces external libvorbis
(string-append "--prefix=" out)
- ;; drop special machine instructions not supported
- ;; on all instances of the target
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '()
- '("--disable-3dnow"
- "--disable-3dnowext"
- "--disable-mmx"
- "--disable-mmxext"
- "--disable-sse"
- "--disable-sse2"))
- "--disable-ssse3"
- "--disable-altivec"
+ ;; Enable runtime cpu detection where supported,
+ ;; and choose a suitable target.
+ ,@(match (or (%current-target-system)
+ (%current-system))
+ ("x86_64-linux"
+ '("--enable-runtime-cpudetection"
+ "--target=x86_64-linux"))
+ ("i686-linux"
+ '("--enable-runtime-cpudetection"
+ "--target=i686-linux"))
+ ("mips64el-linux"
+ '("--target=mips3-linux")))
"--disable-armv5te"
"--disable-armv6"
"--disable-armv6t2"