summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm40
1 files changed, 4 insertions, 36 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c327c9bc5c..2ef92ae630 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -865,26 +865,6 @@ audio/video codec library.")
(base32
"0b59qk5wpc5ksiha76jbhb859g5gxa4w0k6afh3kgvgajiivs73l"))))))
-(define-public ffmpeg-2.8
- (package
- (inherit ffmpeg)
- (version "2.8.15")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
- version ".tar.xz"))
- (sha256
- (base32
- "065xbvnfmxfbfrc14cavpqyd2slil99vcjksw4ndb7w8zdh0wp3v"))))
- (arguments
- (substitute-keyword-arguments (package-arguments ffmpeg)
- ((#:configure-flags flags)
- `(map (lambda (flag)
- (if (string=? flag "--disable-mipsdsp")
- "--disable-mipsdspr1"
- flag))
- ,flags))))))
-
(define-public ffmpegthumbnailer
(package
(name "ffmpegthumbnailer")
@@ -916,31 +896,19 @@ thumbnailer uses ffmpeg to decode frames from the video files, so supported
videoformats depend on the configuration flags of ffmpeg.")
(license license:gpl2+)))
-;; Fix build with newer x264.
-(define %vlc-libx264-compat.patch
- (origin
- (method url-fetch)
- (uri (string-append "https://git.videolan.org/?p=vlc.git;a=patch;h="
- "a8953ba707cca1f2de372ca24513296bcfcdaaa8"))
- (file-name "vlc-libx264-compat.patch")
- (sha256
- (base32
- "04igckbdp3sbp8vh0ihmhcf3yjyyk9r3cd5dm9mn9j6vipi1dg3g"))))
-
(define-public vlc
(package
(name "vlc")
- (version "3.0.4")
+ (version "3.0.5")
(source (origin
(method url-fetch)
(uri (string-append
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
- (patches (list %vlc-libx264-compat.patch))
(sha256
(base32
- "17jsq0zqpqyxw4ckvjba0hf6zk8ywc4wf8sy3z03hh3ij0vxpwq1"))))
+ "1nvj00khy08sing0mdnw6virmiq579mrk5rvpx9710nlxggqgh7m"))))
(build-system gnu-build-system)
(native-inputs
`(("flex" ,flex)
@@ -1338,7 +1306,7 @@ access to mpv's powerful playback capabilities.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2018.11.07")
+ (version "2018.12.17")
(source (origin
(method url-fetch)
(uri (string-append "https://yt-dl.org/downloads/"
@@ -1346,7 +1314,7 @@ access to mpv's powerful playback capabilities.")
version ".tar.gz"))
(sha256
(base32
- "1rvc2m2kbm2kycqsa7fkcg5gql9f0w3hn1a7jg48zzl06ayggxk9"))))
+ "1nd4zr3wd35vldm775m9wcgbzma2013yyj134lcz19ipjs38isrk"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion