summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8362d00f60..3e9d797e2c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -569,30 +569,30 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(define-public loksh
(package
(name "loksh")
- (version "6.3")
+ (version "6.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/dimkr/loksh/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimkr/loksh.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0i1b60g1p19s5cnzz0nmjzjnxywm9szzyp1rcwfcx3gmzvrwr2sc"))))
+ (base32 "1d92cf5iadj1vwg0wwksaq1691zaxjrd2y4qygj4sdd25zsahj6p"))))
(build-system gnu-build-system)
(inputs
- `(("libbsd" ,libbsd)))
+ `(("libbsd" ,libbsd)
+ ("ncurses" ,ncurses)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(#:tests? #f ;No tests included
+ `(#:tests? #f ; no tests included
#:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
- (string-append "DESTDIR="
- (assoc-ref %outputs "out"))
- "PREFIX=")
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ;No configure script
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/dimkr/loksh")
(synopsis "Korn Shell from OpenBSD")
(description