summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index efac79c515..2dedef8373 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -234,10 +234,13 @@ rustc-bootstrap and cargo-bootstrap packages.")
(lambda _
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))))
- (add-after 'unpack 'patch-lockfile-test
- (lambda _
+ (add-after 'unpack 'patch-tests
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/tools/tidy/src/main.rs"
- (("^.*cargo.*::check.*$") ""))))
+ (("^.*cargo.*::check.*$") ""))
+ (substitute* "src/libstd/process.rs"
+ (("\"/bin/sh\"") (string-append "\"" (assoc-ref inputs "bash") "/bin/sh\"")))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))