summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ead34d5b9..f68a1cedd1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15571,3 +15571,28 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Checks syntax of reStructuredText and code blocks nested within it")
(license #f)))
+
+(define-public python-dparse
+ (package
+ (name "python-dparse")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dparse" version))
+ (sha256
+ (base32
+ "10pm9q5r97828rml3pzi428ihf2cpaiw25hssgbax0zxv1sr37vw"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-packaging" ,python-packaging)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/jayfk/dparse")
+ (synopsis "A parser for Python dependency files")
+ (description
+ "A parser for Python dependency files")
+ (license license:expat)))