summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 84b53b00b4..c9a53698bd 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -79,14 +79,14 @@
(define-public poppler
(package
(name "poppler")
- (version "0.62.0")
+ (version "0.63.0")
(source (origin
(method url-fetch)
(uri (string-append "https://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
(sha256
(base32
- "1ii9ly1pngyvs0aiq2wxpya08hidpl54y7nsb8b1vxnnskgp76jv"))))
+ "04d1z1ygyb3llzc6s6c99wxafvljj2sc5b76djif34f7mzfqmk17"))))
(build-system cmake-build-system)
;; FIXME:
;; use libcurl: no
@@ -581,7 +581,7 @@ extracting content or merging files.")
(base32
"0b9j0gqbc3jhmx87r6idcsh8lnb30840c3hyx6dk2gdjqqh3hysp"))
(modules '((guix build utils)))
- (snippet '(delete-file-recursively "thirdparty"))))
+ (snippet '(begin (delete-file-recursively "thirdparty") #t))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -633,12 +633,14 @@ line tools for batch rendering @command{pdfdraw}, rewriting files
(snippet
;; Replace shebang with the bi-lingual shell/Perl trick to remove
;; dependency on Perl.
- '(substitute* "qpdf/fix-qdf"
- (("#!/usr/bin/env perl")
- "\
+ '(begin
+ (substitute* "qpdf/fix-qdf"
+ (("#!/usr/bin/env perl")
+ "\
eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
& eval 'exec perl -wS \"$0\" $argv:q'
- if 0;\n")))))
+ if 0;\n"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,perl)
@@ -652,7 +654,8 @@ eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
(substitute* (append
'("qtest/bin/qtest-driver")
(find-files "." "\\.test"))
- (("/usr/bin/env") (which "env"))))))))
+ (("/usr/bin/env") (which "env")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("perl" ,perl)))