summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/meson-for-build-rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/meson-for-build-rpath.patch')
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
index 4e20c9aed3..2151d53565 100644
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -6,14 +6,13 @@ Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
-@@ -345,15 +345,6 @@
+@@ -391,14 +391,6 @@
print("Symlink creation does not work on this platform. "
"Skipping all symlinking.")
printed_symlink_error = True
-- if is_elf_platform() and os.path.isfile(outname):
+- if os.path.isfile(outname):
- try:
-- e = depfixer.Elf(outname, False)
-- e.fix_rpath(install_rpath)
+- depfixer.fix_rpath(outname, install_rpath, False)
- except SystemExit as e:
- if isinstance(e.code, int) and e.code == 0:
- pass