summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ldc-bootstrap-disable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ldc-bootstrap-disable-tests.patch')
-rw-r--r--gnu/packages/patches/ldc-bootstrap-disable-tests.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/patches/ldc-bootstrap-disable-tests.patch b/gnu/packages/patches/ldc-bootstrap-disable-tests.patch
new file mode 100644
index 0000000000..d2e40b8016
--- /dev/null
+++ b/gnu/packages/patches/ldc-bootstrap-disable-tests.patch
@@ -0,0 +1,72 @@
+This patch fixes a failing unit test by feeding buildNormalizedPath to the
+tzdata properly. Three other tests are disabled, one assumes /root and the
+two others use networking. Not bad out of almost 700 tests!
+
+by Pjotr Prins <pjotr.guix@thebird.nl>
+
+--- a/std/datetime.d.orig 2016-11-24 01:13:52.584495545 +0100
++++ b/std/datetime.d 2016-11-24 01:17:09.655306728 +0100
+@@ -28081,22 +28081,24 @@
+ import std.range : retro;
+ import std.format : format;
+
+- name = strip(name);
+-
+ enforce(tzDatabaseDir.exists(), new DateTimeException(format("Directory %s does not exist.", tzDatabaseDir)));
+ enforce(tzDatabaseDir.isDir, new DateTimeException(format("%s is not a directory.", tzDatabaseDir)));
+
+ version(Android)
+ {
++ name = strip(name);
+ auto tzfileOffset = name in tzdataIndex(tzDatabaseDir);
+ enforce(tzfileOffset, new DateTimeException(format("The time zone %s is not listed.", name)));
+ string tzFilename = separate_index ? "zoneinfo.dat" : "tzdata";
+ immutable file = buildNormalizedPath(tzDatabaseDir, tzFilename);
+ }
+ else
+- immutable file = buildNormalizedPath(tzDatabaseDir, name);
++ {
++ auto filename = "./" ~ strip(name); // make sure the prefix is not stripped
++ immutable file = buildNormalizedPath(tzDatabaseDir, filename);
++ }
+
+- enforce(file.exists(), new DateTimeException(format("File %s does not exist.", file)));
++ enforce(file.exists(), new DateTimeException(format("File %s does not exist in %s.", file, tzDatabaseDir)));
+ enforce(file.isFile, new DateTimeException(format("%s is not a file.", file)));
+
+ auto tzFile = File(file);
+diff --git a/std/path.d b/std/path.d
+index 254d8f0..b0fc04d 100644
+--- a/std/path.d
++++ b/std/path.d
+@@ -3080,8 +3080,11 @@ unittest
+ }
+ else
+ {
++ pragma(msg, "test disabled on GNU Guix");
++/*
+ assert(expandTilde("~root") == "/root", expandTilde("~root"));
+ assert(expandTilde("~root/") == "/root/", expandTilde("~root/"));
++*/
+ }
+ assert(expandTilde("~Idontexist/hey") == "~Idontexist/hey");
+ }
+diff --git a/std/socket.d b/std/socket.d
+index b85d1c9..7fbf346 100644
+--- a/std/socket.d
++++ b/std/socket.d
+@@ -859,6 +862,8 @@ class InternetHost
+
+ unittest
+ {
++ pragma(msg, "test disabled on GNU Guix");
++ /*
+ InternetHost ih = new InternetHost;
+
+ ih.getHostByAddr(0x7F_00_00_01);
+@@ -889,6 +894,7 @@ unittest
+ // writefln("aliases[%d] = %s", i, s);
+ // }
+ });
++ */
+ }