summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm56
1 files changed, 54 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0a2f266a7d..5e7d7b2bd3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1312,7 +1313,7 @@ can solve two kinds of problems:
(define-public octave
(package
(name "octave")
- (version "4.2.1")
+ (version "4.2.2")
(source
(origin
(method url-fetch)
@@ -1320,7 +1321,7 @@ can solve two kinds of problems:
version ".tar.lz"))
(sha256
(base32
- "09zhhch79jw3ynw39vizx0i2cbd2bjz3sp38pjdzraqrbivpwp92"))))
+ "0pkkz1vazsh7ipffb09q0nc2jgx6q27pkkngygjij6jrpcly5zsp"))))
(build-system gnu-build-system)
(inputs
`(("lapack" ,lapack)
@@ -3769,3 +3770,54 @@ specifications. Also, state spaces can be manipulated, visualised and
analysed.")
(home-page "http://mcrl2.org")
(license license:boost1.0)))
+
+(define-public r-subplex
+ (package
+ (name "r-subplex")
+ (version "1.5-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "subplex" version))
+ (sha256
+ (base32
+ "1v9xrnkapnq7v1jbhlg32ignklzf2vn8rqpayc8pzk8wvz53r33g"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/subplex")
+ (synopsis "Unconstrained optimization using the subplex algorithm")
+ (description "This package implements the Subplex optimization algorithm.
+It solves unconstrained optimization problems using a simplex method on
+subspaces. The method is well suited for optimizing objective functions that
+are noisy or are discontinuous at the solution.")
+ (license license:gpl3+)))
+
+(define-public r-desolve
+ (package
+ (name "r-desolve")
+ (version "1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "deSolve" version))
+ (sha256
+ (base32
+ "18nx3maww979a8p8ly4hv63y65mnjx8vbj2fpipd6rhcbf1lbsan"))))
+ (properties `((upstream-name . "deSolve")))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://desolve.r-forge.r-project.org/")
+ (synopsis "Solvers for initial value problems of differential equations")
+ (description "This package provides functions that solve initial
+value problems of a system of first-order ordinary differential equations (ODE),
+of partial differential equations (PDE), of differential algebraic equations
+(DAE), and of delay differential equations. The functions provide an interface
+to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
+to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
+the Runge-Kutta family with fixed or variable time steps. The package contains
+routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
+differential equations (PDE) that have been converted to ODEs by numerical
+differencing.")
+ (license license:gpl2+)))