summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 024e75aaa1..5435f89c42 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -947,14 +947,15 @@ useful features.")
(define-public libetpan
(package
(name "libetpan")
- (version "1.8")
+ (version "1.9.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/dinhviethoa/" name
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dinhviethoa/libetpan.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1sxnaglp5hb0z78sgnfzva4x8m4flqhicvm1dz0krkxdmfsafrsf"))))
+ (base32 "1628lb1qvxixl64ifvjjr839hmirpx532klhv2mr7m6gmn7nlci5"))))
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
@@ -978,7 +979,7 @@ useful features.")
(invoke "sh" "autogen.sh"))))
#:configure-flags
'("--disable-static" "--disable-db")))
- (home-page "http://www.etpan.org/libetpan.html")
+ (home-page "https://www.etpan.org/libetpan.html")
(synopsis "Portable middleware for email access")
(description
"The purpose of this mail library is to provide a portable, efficient