summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm136
1 files changed, 111 insertions, 25 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5e8b6fdd3d..261e720e2b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,6 +69,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages gtk)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages xdisorg)
#:use-module (ice-9 match)
#:use-module (srfi srfi-19))
@@ -83,8 +85,8 @@
,lisp))))
(define-public gcl
- (let ((commit "5956140b1083e2302a59d7ce2054b0b7c2cbb417")
- (revision "1")) ;Guix package revision
+ (let ((commit "d3335e2b3deb63f930eb0328e9b05377744c9512")
+ (revision "2")) ;Guix package revision
(package
(name "gcl")
(version (string-append "2.6.12-" revision "."
@@ -97,7 +99,7 @@
(commit commit)))
(file-name (string-append "gcl-" version "-checkout"))
(sha256
- (base32 "0mwclf2879mh3d9xqkqhghf58lwy7srsnsq9x0f1cc6j302sy4hb"))))
+ (base32 "05v86lhvsby05nzvcd3c4k0wljvgdgd0i6arzd2fx1yd67dl6fgj"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; The build system seems not to be thread safe.
@@ -167,8 +169,7 @@
`(("gmp" ,gmp)
("readline" ,readline)))
(native-inputs
- `(("gcc" ,gcc-4.9)
- ("m4" ,m4)
+ `(("m4" ,m4)
("texinfo" ,texinfo)))
(home-page "https://www.gnu.org/software/gcl/")
(synopsis "A Common Lisp implementation")
@@ -771,6 +772,42 @@ thin compatibility layer for gray streams.")
(define-public ecl-trivial-gray-streams
(sbcl-package->ecl-package sbcl-trivial-gray-streams))
+(define-public sbcl-fiasco
+ (let ((commit "d62f7558b21addc89f87e306f65d7f760632655f")
+ (revision "1"))
+ (package
+ (name "sbcl-fiasco")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joaotavora/fiasco.git")
+ (commit commit)))
+ (file-name (git-file-name "fiasco" version))
+ (sha256
+ (base32
+ "1zwxs3d6iswayavcmb49z2892xhym7n556d8dnmvalc32pm9bkjh"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+ (synopsis "Simple and powerful test framework for Common Lisp")
+ (description "A Common Lisp test framework that treasures your failures,
+logical continuation of Stefil. It focuses on interactive debugging.")
+ (home-page "https://github.com/joaotavora/fiasco")
+ ;; LICENCE specifies this is public-domain unless the legislation
+ ;; doesn't allow or recognize it. In that case it falls back to a
+ ;; permissive licence.
+ (license (list license:public-domain
+ (license:x11-style "file://LICENCE"))))))
+
+(define-public cl-fiasco
+ (sbcl-package->cl-source-package sbcl-fiasco))
+
+(define-public ecl-fiasco
+ (sbcl-package->ecl-package sbcl-fiasco))
+
(define-public sbcl-flexi-streams
(package
(name "sbcl-flexi-streams")
@@ -928,25 +965,31 @@ from other CLXes around the net.")
`(("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
("sbcl-cl-unicode" ,sbcl-cl-unicode)))))
-(define-public sbcl-stumpwm
+(define-public stumpwm
(package
- (name "sbcl-stumpwm")
- (version "18.05")
+ (name "stumpwm")
+ (version "18.11")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/stumpwm/stumpwm/archive/"
version ".tar.gz"))
(sha256
- (base32 "1n2gaab3lwgf5r1hmwdcw13dkv9xdd7drn2shx28kfxvhdc9kbb9"))
- (file-name (string-append "stumpwm-" version ".tar.gz"))))
+ (base32 "177gxfk4c127i9crghx6fmkipznhgylvzgnjb2pna38g21gg6s39"))
+ (file-name (string-append "stumpwm-" version ".tar.gz"))
+ (patches
+ ;; This patch is included in the post-18.11 git master tree
+ ;; and can be removed when we move to the next release.
+ (search-patches "stumpwm-fix-broken-read-one-line.patch"))))
(build-system asdf-build-system/sbcl)
+ (native-inputs `(("fiasco" ,sbcl-fiasco)))
(inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
("clx" ,sbcl-clx)
("alexandria" ,sbcl-alexandria)))
(outputs '("out" "lib"))
(arguments
- '(#:phases
+ '(#:asd-system-name "stumpwm"
+ #:phases
(modify-phases %standard-phases
(add-after 'create-symlinks 'build-program
(lambda* (#:key outputs #:allow-other-keys)
@@ -979,17 +1022,15 @@ for input. These design decisions reflect the growing popularity of
productive, customizable lisp based systems.")
(home-page "https://github.com/stumpwm/stumpwm")
(license license:gpl2+)
- (properties `((ecl-variant . ,(delay ecl-stumpwm))))))
+ (properties `((cl-source-variant . ,(delay cl-stumpwm))))))
-(define-public cl-stumpwm
- (sbcl-package->cl-source-package sbcl-stumpwm))
+(define-public sbcl-stumpwm
+ (deprecated-package "sbcl-stumpwm" stumpwm))
-(define-public ecl-stumpwm
- (let ((base (sbcl-package->ecl-package sbcl-stumpwm)))
- (package
- (inherit base)
- (outputs '("out"))
- (arguments '()))))
+(define-public cl-stumpwm
+ (package
+ (inherit (sbcl-package->cl-source-package stumpwm))
+ (name "cl-stumpwm")))
;; The slynk that users expect to install includes all of slynk's contrib
;; modules. Therefore, we build the base module and all contribs first; then
@@ -1268,16 +1309,16 @@ multiple inspectors with independent history.")
paths)
#t)))))))
-(define-public sbcl-stumpwm+slynk
+(define-public stumpwm+slynk
(package
- (inherit sbcl-stumpwm)
- (name "sbcl-stumpwm-with-slynk")
+ (inherit stumpwm)
+ (name "stumpwm-with-slynk")
(outputs '("out"))
(inputs
- `(("stumpwm" ,sbcl-stumpwm "lib")
+ `(("stumpwm" ,stumpwm "lib")
("slynk" ,sbcl-slynk)))
(arguments
- (substitute-keyword-arguments (package-arguments sbcl-stumpwm)
+ (substitute-keyword-arguments (package-arguments stumpwm)
((#:phases phases)
`(modify-phases ,phases
(replace 'build-program
@@ -1301,6 +1342,9 @@ multiple inspectors with independent history.")
(delete 'cleanup)
(delete 'create-symlinks)))))))
+(define-public sbcl-stumpwm+slynk
+ (deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))
+
(define-public sbcl-parse-js
(let ((commit "fbadc6029bec7039602abfc06c73bb52970998f6")
(revision "1"))
@@ -3741,3 +3785,45 @@ client and server.")
(define-public ecl-s-xml-rpc
(sbcl-package->ecl-package sbcl-s-xml-rpc))
+
+(define-public sbcl-trivial-clipboard
+ (let ((commit "5af3415d1484e6d69a1b5c178f24680d9fd01796"))
+ (package
+ (name "sbcl-trivial-clipboard")
+ (version (git-version "0.0.0.0" "2" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/snmsts/trivial-clipboard")
+ (commit commit)))
+ (file-name (git-file-name "trivial-clipboard" version))
+ (sha256
+ (base32
+ "1gb515z5yq6h5548pb1fwhmb0hhq1ssyb78pvxh4alq799xipxs9"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("xclip" ,xclip)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/text.lisp"
+ (("\\(executable-find \"xclip\"\\)")
+ (string-append "(executable-find \""
+ (assoc-ref inputs "xclip")
+ "/bin/xclip\")"))))))))
+ (home-page "https://github.com/snmsts/trivial-clipboard")
+ (synopsis "Access system clipboard in Common Lisp")
+ (description
+ "@command{trivial-clipboard} gives access to the system clipboard.")
+ (license license:expat))))
+
+(define-public cl-trivial-clipboard
+ (sbcl-package->cl-source-package sbcl-trivial-clipboard))
+
+(define-public ecl-trivial-clipboard
+ (sbcl-package->ecl-package sbcl-trivial-clipboard))