summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm29
1 files changed, 20 insertions, 9 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 4f4e494ee5..ba31d36b9e 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -30,6 +30,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages aspell)
#:use-module (gnu packages autogen)
#:use-module (gnu packages autotools)
@@ -65,7 +66,7 @@
(define-public quassel
(package
(name "quassel")
- (version "0.12.5")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
@@ -73,7 +74,7 @@
version ".tar.bz2"))
(sha256
(base32
- "1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
+ "0xp9mppxl63qzgsdyprmblvfrj0bb9z57kfc088gvcavvq1210nr"))
(modules '((guix build utils)))
;; We don't want to install the bundled scripts.
(snippet
@@ -86,21 +87,31 @@
(arguments
;; The three binaries are not mutually exlusive, and are all built
;; by default.
- '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.2 MiB
- ;;"-DWANT_CORE=OFF" ; 2.4 MiB
- ;;"-DWANT_MONO=OFF" ; 6.4 MiB
- "-DUSE_QT5=ON" ; default is qt4
+ '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 6.1 MiB
+ ;;"-DWANT_CORE=OFF" ; 3.0 MiB
+ ;;"-DWANT_MONO=OFF" ; 7.6 MiB
"-DWITH_KDE=OFF" ; no to kde integration ...
- "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
- "-DWITH_WEBKIT=OFF") ; we don't depend on qtwebkit
+ "-DWITH_BUNDLED_ICONS=ON" ; so we install bundled icons
+ "-DWITH_OXYGEN_ICONS=ON" ; also the oxygen ones
+ "-DWITH_WEBENGINE=OFF") ; we don't depend on qtwebengine
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-inxi-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((inxi (string-append (assoc-ref inputs "inxi") "/bin/inxi")))
+ (substitute* "src/common/aliasmanager.cpp"
+ ((" inxi ") (string-append " " inxi " ")))
+ #t))))
#:tests? #f)) ; no test target
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(inputs
- `(("qca" ,qca)
+ `(("inxi" ,inxi-minimal)
+ ("qca" ,qca)
("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
("qtscript" ,qtscript)
("snorenotify" ,snorenotify)
("zlib" ,zlib)))