summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm65
1 files changed, 22 insertions, 43 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b367e0799c..1113df1ca6 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -254,13 +254,13 @@ files. It can compress them as much as 40% losslessly.")
(define-public libjpeg
(package
(name "libjpeg")
- (version "9b")
+ (version "9c")
(source (origin
(method url-fetch)
(uri (string-append "http://www.ijg.org/files/jpegsrc.v"
version ".tar.gz"))
(sha256 (base32
- "0lnhpahgdwlrkd41lx6cr90r199f8mc6ydlh7jznj5klvacd63r4"))))
+ "08kixcf3a7s9x91174abjnk1xbvj4v8crdc73zi4k9h3jfbm00k5"))))
(build-system gnu-build-system)
(synopsis "Library for handling JPEG files")
(description
@@ -402,7 +402,6 @@ extracting icontainer icon files.")
(define-public libtiff
(package
(name "libtiff")
- (replacement libtiff/fixed)
(version "4.0.9")
(source
(origin
@@ -413,7 +412,9 @@ extracting icontainer icon files.")
(base32
"1kfg4q01r4mqn7dj63ifhi6pmqzbf4xax6ni6kkk81ri5kndwyvf"))
(patches (search-patches "libtiff-CVE-2017-9935.patch"
- "libtiff-CVE-2017-18013.patch"))))
+ "libtiff-CVE-2017-18013.patch"
+ "libtiff-CVE-2018-8905.patch"
+ "libtiff-CVE-2018-10963.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.3 MiB of HTML documentation
@@ -435,17 +436,6 @@ collection of tools for doing simple manipulations of TIFF images.")
"See COPYRIGHT in the distribution."))
(home-page "http://www.simplesystems.org/libtiff/")))
-(define libtiff/fixed
- (package
- (inherit libtiff)
- (source
- (origin
- (inherit (package-source libtiff))
- (patches
- (append (origin-patches (package-source libtiff))
- (search-patches "libtiff-CVE-2018-8905.patch"
- "libtiff-CVE-2018-10963.patch")))))))
-
(define-public leptonica
(package
(name "leptonica")
@@ -503,18 +493,18 @@ arithmetic ops.")
(define-public jbig2dec
(package
(name "jbig2dec")
- (version "0.14")
- (replacement jbig2dec-0.15)
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/ArtifexSoftware/ghostpdl-downloads/"
- "releases/download/gs922/" name "-" version ".tar.gz"))
- (sha256
- (base32 "0k01hp0q4275fj4rbr1gy64svfraw5w7wvwl08yjhvsnpb1rid11"))
- (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
+ (version "0.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ArtifexSoftware"
+ "/ghostpdl-downloads/releases/download"
+ "/gs924/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m1qwpbjbirgw2fqznbajdhdhh35d6xa2csr64lpjz735pvimykb"))
+ (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
(build-system gnu-build-system)
+ (arguments '(#:configure-flags '("--disable-static")))
(synopsis "Decoder of the JBIG2 image compression format")
(description
"JBIG2 is designed for lossy or lossless encoding of 'bilevel' (1-bit
@@ -529,21 +519,6 @@ work.")
(home-page "https://jbig2dec.com")
(license license:gpl2+)))
-;; This is a bugfix release from an ongoing Ghostscript security audit.
-;; It was released alongside Ghostscript 9.24.
-(define-public jbig2dec-0.15
- (package
- (inherit jbig2dec)
- (version "0.15")
- (source (origin
- (inherit (package-source jbig2dec))
- (uri (string-append "https://github.com/ArtifexSoftware"
- "/ghostpdl-downloads/releases/download/gs924/"
- "jbig2dec-" version ".tar.gz"))
- (sha256
- (base32
- "0m1qwpbjbirgw2fqznbajdhdhh35d6xa2csr64lpjz735pvimykb"))))))
-
(define-public openjpeg
(package
(name "openjpeg")
@@ -850,11 +825,15 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
`(#:test-target "check"
#:phases
(modify-phases %standard-phases
- ;; See https://github.com/ukoethe/vigra/issues/432
- (add-after 'unpack 'disable-broken-test
+ (add-after 'unpack 'disable-broken-tests
(lambda _
+ ;; See https://github.com/ukoethe/vigra/issues/432
(substitute* "test/fourier/CMakeLists.txt"
(("VIGRA_ADD_TEST.*") ""))
+ ;; This test fails with Numpy 1.15:
+ ;; <https://github.com/ukoethe/vigra/issues/436>.
+ (substitute* "vigranumpy/test/CMakeLists.txt"
+ (("test1\\.py") ""))
#t)))
#:configure-flags
(list "-Wno-dev" ; suppress developer mode with lots of warnings