summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm39
1 files changed, 11 insertions, 28 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1ba281205c..cee7f146fa 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -107,41 +107,24 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
(define-public libtiff
(package
(name "libtiff")
- (version "4.0.3")
+ (version "4.0.5")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
version ".tar.gz"))
(sha256 (base32
- "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))
- (patches (map search-patch '("libtiff-CVE-2012-4564.patch"
- "libtiff-CVE-2013-1960.patch"
- "libtiff-CVE-2013-1961.patch"
- "libtiff-CVE-2013-4231.patch"
- "libtiff-CVE-2013-4232.patch"
- "libtiff-CVE-2013-4244.patch"
- "libtiff-CVE-2013-4243.patch"
- "libtiff-CVE-2014-9330.patch"
- "libtiff-CVE-2014-8127-pt1.patch"
- "libtiff-CVE-2014-8127-pt2.patch"
- "libtiff-CVE-2014-8127-pt3.patch"
- "libtiff-CVE-2014-8127-pt4.patch"
- "libtiff-CVE-2014-8128-pt1.patch"
- "libtiff-CVE-2014-8128-pt2.patch"
- "libtiff-CVE-2014-8128-pt3.patch"
- "libtiff-CVE-2014-8129.patch"
- "libtiff-CVE-2014-9655.patch"
- "libtiff-CVE-2014-8128-pt4.patch"
- "libtiff-CVE-2014-8128-pt5.patch")))))
+ "171hgy4mylwmvdm7gp6ffjva81m4j56v3fbqsbfl7avzxn1slpp2"))))
(build-system gnu-build-system)
- (inputs `(("zlib" ,zlib)
- ("libjpeg-8" ,libjpeg-8)))
- ;; currently does not compile with libjpeg version 9
+ (outputs '("out"
+ "doc")) ;1.3 MiB of HTML documentation
(arguments
- `(#:configure-flags
- (list (string-append "--with-jpeg-include-dir="
- (assoc-ref %build-inputs "libjpeg-8")
- "/include"))))
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ `(#:configure-flags (list (string-append "--with-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/"
+ ,name "-" ,version))))
+ (inputs `(("zlib" ,zlib)
+ ("libjpeg" ,libjpeg)))
(synopsis "Library for handling TIFF files")
(description
"Libtiff provides support for the Tag Image File Format (TIFF), a format