summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm114
1 files changed, 112 insertions, 2 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index f77336e504..52bc3d0527 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -18,6 +18,7 @@
(define-module (gnu packages hardware)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -35,14 +36,14 @@
(define-public ddcutil
(package
(name "ddcutil")
- (version "0.9.1")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.ddcutil.com/tarballs/"
name "-" version ".tar.gz"))
(sha256
- (base32 "1b4bm3zhk5vnad6fxf0mn8nrlj3fngifl7nzxgxw0n56hlv7ccv0"))))
+ (base32 "0nhi261vf2n3jpi0a0n6659911kxi3lj7a4h7cmv0ip6sbb8rk88"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -74,6 +75,115 @@ calibrated, and restored when the calibration is applied.")
(license (list license:bsd-3 ; FindDDCUtil.cmake
license:gpl2+)))) ; everything else
+;; Distinct from memtest86, which is obsolete.
+(define-public memtest86+
+ (package
+ (name "memtest86+")
+ ;; Update the description when/if UEFI support is released.
+ (version "5.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.memtest.org/download/5.01/memtest86+-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0fch1l55753y6jkk0hj8f6vw4h1kinkn9ysp22dq5g9zjnvjf88l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:system "i686-linux" ; the result runs outside of any OS
+ #:tests? #f ; no way to test this
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'build
+ ;; The default 'make all' does wonderful things, like scp(1) a file to
+ ;; 192.168.0.12. Build the bootable images and nothing more.
+ (lambda _
+ (invoke "make"
+ "memtest" ; ELF executable
+ "memtest.bin"))) ; DOS/MBR boot sector
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/memtest86+"))
+ (doc (string-append out "/share/doc/memtest86+-" ,version)))
+ (for-each
+ (lambda (file)
+ (install-file file lib))
+ (list "memtest"
+ "memtest.bin"))
+ (for-each
+ (lambda (file)
+ (install-file file doc))
+ (list "FAQ"
+ "README"))
+ #t))))))
+ (native-inputs
+ ;; Newer GCCs fail with a deluge of "multiple definition of `__foo'" errors.
+ `(("gcc" ,gcc-4.9)))
+ (supported-systems (list "i686-linux" "x86_64-linux"))
+ (home-page "https://www.memtest.org/")
+ (synopsis "Thorough real-mode memory tester")
+ (description
+ "Memtest86+ is a thorough, stand-alone memory test for x86 systems. It
+repeatedly writes different patterns to all memory locations, reads them back
+again, and verifies whether the result is the same as what was written. This
+can help debug even intermittent and non-deterministic errors.
+
+It runs independently of any operating system, at computer boot-up, so that it
+can scan as much of your RAM as possible for hardware defects.
+
+Memtest86+ cannot currently be used on computers booted with UEFI.")
+ (license license:gpl2)))
+
+(define-public memtester
+ (package
+ (name "memtester")
+ (version "4.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Even the latest release is available under 'old-versions/'.
+ (uri (string-append "http://pyropus.ca/software/memtester/old-versions/"
+ "memtester-" version ".tar.gz"))
+ (sha256
+ (base32 "127xymmyzb9r6dxqrwd69v7gf8csv8kv7fjvagbglf3wfgyy5pzr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; This is a home-brewed configuration system where the cc/ld command
+ ;; lines are stored in one-line files.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (substitute* (list "conf-cc" "conf-ld")
+ (("^cc") "gcc"))
+ (substitute* "Makefile"
+ (("(INSTALLPATH.*=).*" _ assignment)
+ (string-append assignment out)))
+ #t)))
+ (replace 'check
+ ;; There is no test suite. Test some RAM for a single iteration.
+ (lambda _
+ (invoke "./memtester" "64K" "1"))))))
+ (home-page "http://pyropus.ca/software/memtester/")
+ (synopsis "User-space memory subsystem tester")
+ (description
+ "Memtester stress-tests the memory subsystem of your operating system and
+computer. It repeatedly writes different patterns to all memory locations,
+reads them back again, and verifies whether the result is the same as what was
+written. This can help debug even intermittent and non-deterministic errors.
+
+Memtester runs entirely in user space. This means that you don't need to reboot
+to test your memory, but also that it's not possible to test all of the RAM
+installed in the system.
+
+It can also be told to test memory starting at a particular physical address.")
+ (license license:gpl2)))
+
(define-public msr-tools
(package
(name "msr-tools")