summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 30d2e2612c..f2a252b8d3 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -850,27 +850,18 @@ The library is shipped with documentation in Info format and usage examples.")
(define-public guile-lib
(package
(name "guile-lib")
- (version "0.2.6")
+ (version "0.2.6.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-lib/guile-lib-"
version ".tar.gz"))
(sha256
(base32
- "0n1lf5bsr5s9gqi07sdfkl1hpin6dzvkcj1xa63jd1w8aglwv8r1"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; 'pre-inst-env' sets an incorrect load path, missing the
- ;; "/src" bit. Add it.
- (substitute* "pre-inst-env.in"
- (("abs_top_(builddir|srcdir)=([[:graph:]]+)" _ dir value)
- (string-append "abs_top_" dir "=" value "/src")))
- #t))))
+ "0aizxdif5dpch9cvs8zz5g8ds5s4xhfnwza2il5ji7fv2h7ks7bd"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
- '("GUILE_AUTO_COMPILE=0") ;to prevent guild errors
+ '("GUILE_AUTO_COMPILE=0") ; to prevent guild errors
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-module-dir
@@ -1243,7 +1234,6 @@ above command-line parameters.")
("automake" ,automake)
("pkg-config" ,pkg-config)
("guile" ,guile-2.2)))
- (home-page "https://savannah.nongnu.org/projects/guile-redis/")
(synopsis "Redis client library for Guile")
(description "Guile-redis provides a Scheme interface to the Redis
key-value cache and store.")