summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm104
1 files changed, 49 insertions, 55 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 84b535d19d..cca0edbbf3 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -77,8 +77,10 @@
(modules '((guix build utils)))
(snippet
;; Fix incompatibility with Perl 5.22+.
- '(substitute* '("js/src/config/milestone.pl")
- (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE")))))
+ '(begin
+ (substitute* '("js/src/config/milestone.pl")
+ (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)
@@ -96,7 +98,9 @@
(modify-phases %standard-phases
(add-after 'unpack 'delete-timedout-test
;; This test times out on slower hardware.
- (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js")))
+ (lambda _
+ (delete-file "js/src/jit-test/tests/basic/bug698584.js")
+ #t))
(add-before 'configure 'chdir
(lambda _
(chdir "js/src")
@@ -107,12 +111,11 @@
(let ((out (assoc-ref outputs "out")))
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system*
- "./configure" (string-append "--prefix=" out)
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())))))))))
+ (invoke "./configure" (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '()))))))))
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
(synopsis "Mozilla javascript engine")
@@ -136,8 +139,10 @@ in C/C++.")
(patches (search-patches "mozjs24-aarch64-support.patch"))
(snippet
;; Fix incompatibility with Perl 5.22+.
- '(substitute* '("js/src/config/milestone.pl")
- (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE")))))
+ '(begin
+ (substitute* '("js/src/config/milestone.pl")
+ (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE"))
+ #t))))
(arguments
(substitute-keyword-arguments (package-arguments mozjs)
((#:phases phases)
@@ -148,15 +153,15 @@ in C/C++.")
;; configure fails if it is followed by SHELL and CONFIG_SHELL
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- "--with-system-nspr"
- "--enable-system-ffi"
- "--enable-threadsafe"
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '()))))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--with-system-nspr"
+ "--enable-system-ffi"
+ "--enable-threadsafe"
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())))))))))
(inputs
`(("libffi" ,libffi)
("zlib" ,zlib)))))
@@ -220,23 +225,23 @@ in C/C++.")
(chdir "js/src")
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- "--enable-ctypes"
- "--enable-gcgenerational"
- "--enable-optimize"
- "--enable-pie"
- "--enable-readline"
- "--enable-shared-js"
- "--enable-system-ffi"
- "--enable-threadsafe"
- "--enable-xterm-updates"
- "--with-system-icu"
- "--with-system-nspr"
- "--with-system-zlib"
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--enable-ctypes"
+ "--enable-gcgenerational"
+ "--enable-optimize"
+ "--enable-pie"
+ "--enable-readline"
+ "--enable-shared-js"
+ "--enable-system-ffi"
+ "--enable-threadsafe"
+ "--enable-xterm-updates"
+ "--with-system-icu"
+ "--with-system-nspr"
+ "--with-system-zlib"
- ;; Intl API requires bundled ICU.
- "--without-intl-api"))))))))
+ ;; Intl API requires bundled ICU.
+ "--without-intl-api")))))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)
@@ -340,7 +345,7 @@ in the Mozilla clients.")
(setenv "DOMSUF" "(none)")
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
- (zero? (system* "./nss/tests/all.sh"))))
+ (invoke "./nss/tests/all.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -660,19 +665,6 @@ security standards.")
#t))
#t)))
(add-after
- 'unpack 'use-skia-by-default
- (lambda _
- ;; Use the bundled Skia library by default, since IceCat appears
- ;; to be far more stable when using it than when using our system
- ;; Cairo.
- (let ((out (open "browser/app/profile/icecat.js"
- (logior O_WRONLY O_APPEND))))
- (format out "~%// Use Skia by default~%")
- (format out "pref(~s, ~s);~%" "gfx.canvas.azure.backends" "skia")
- (format out "pref(~s, ~s);~%" "gfx.content.azure.backends" "skia")
- (close-port out))
- #t))
- (add-after
'unpack 'link-libxul-with-libraries
(lambda _
;; libxul.so dynamically opens libraries, so here we explicitly
@@ -708,9 +700,9 @@ security standards.")
(chdir "../build")
(format #t "build directory: ~s~%" (getcwd))
(format #t "configure flags: ~s~%" flags)
- (zero? (apply system* bash
- (string-append srcdir "/configure")
- flags)))))
+ (apply invoke bash
+ (string-append srcdir "/configure")
+ flags))))
(add-before 'configure 'install-desktop-entry
(lambda* (#:key outputs #:allow-other-keys)
;; Install the '.desktop' file.
@@ -765,7 +757,8 @@ security standards.")
(copy-file file (string-append icons "/icecat.png"))))
'("default16.png" "default22.png" "default24.png"
"default32.png" "default48.png" "content/icon64.png"
- "mozicon128.png" "default256.png"))))))
+ "mozicon128.png" "default256.png"))
+ #t))))
;; This fixes the file chooser crash that happens with GTK 3.
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -774,7 +767,8 @@ security standards.")
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share")))
(wrap-program (car (find-files lib "^icecat$"))
- `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))))
+ `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))
+ #t))))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")
(description