summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm76
1 files changed, 46 insertions, 30 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b497b965bc..5dcf9b1f5f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -31,6 +31,8 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -95,6 +97,7 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages inkscape)
#:use-module (gnu packages ibus)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages libcanberra)
@@ -151,6 +154,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization)
#:use-module (gnu packages vpn)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -2217,19 +2221,31 @@ selection and URL hints.")))
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
- (patches ; We have to revert 2 commits to build against freerdp 1.1.
- (search-patches "vinagre-revert-1.patch"
- "vinagre-revert-2.patch"))
+ (patches (search-patches "vinagre-newer-freerdp.patch"
+ "vinagre-newer-rdp-parameters.patch"))
(sha256
(base32
"10jya3jyrm18nbw3v410gbkc7677bqamax44pzgd3j15randn76d"))))
(build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Don't create 'icon-theme.cache'
+ (substitute* (find-files "." "^Makefile$")
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'unpack 'patch-configure
+ (lambda _
+ (substitute* "configure"
+ (("freerdp") "freerdp2"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
("itstool" ,itstool)
- ("glib-bin" ,glib "bin") ;for glib-compile-schemas
- ("gtk+-bin" ,gtk+ "bin"))) ;for gtk-update-icon-cache
+ ("glib-bin" ,glib "bin"))) ;for glib-compile-schemas
(inputs
`(("libxml2" ,libxml2)
("gtk-vnc" ,gtk-vnc)
@@ -2240,8 +2256,6 @@ selection and URL hints.")))
("spice-gtk" ,spice-gtk)
("telepathy-glib" ,telepathy-glib)
("vte" ,vte)))
- (arguments
- `(#:configure-flags '("--enable-rdp")))
(home-page "https://wiki.gnome.org/Apps/Vinagre")
(synopsis "Remote desktop viewer for GNOME")
(description "Vinagre is a remote display client supporting the VNC, SPICE
@@ -4630,14 +4644,6 @@ configuration program to choose applications starting on login.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'set-paths 'work-around-gcc-7-include-path-issue
- ;; FIXME: Work around a problem with gcc-7 includes (see
- ;; <https://bugs.gnu.org/30756>). Note that we use gcc-7
- ;; to work around an internal compiler error in gcc-5.
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(add-before
'check 'pre-check
(lambda _
@@ -4655,11 +4661,7 @@ configuration program to choose applications starting on login.")
((".*expect\\(datestr\\).*") ""))
#t)))))
(native-inputs
- `(("gcc" ,gcc-7) ; FIXME: Work around an internal compiler error in
- ; gcc-5. Try removing this when our default compiler is
- ; no longer gcc-5.5.0, and also remove the
- ; 'work-around-gcc-7-include-path-issue' phase above.
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)
;; For testing
@@ -5346,6 +5348,10 @@ libxml2.")
;; script. It provides a generic one if --enable-gdm-xsession is set.
"--enable-gdm-xsession"
+ ;; Use '/etc/environment' for locale settings instead of the
+ ;; systemd-specific '/etc/locale.conf'.
+ "--with-lang-file=/etc/environment"
+
"--localstatedir=/var"
,(string-append "--with-default-path="
(string-join '("/run/setuid-programs"
@@ -5408,6 +5414,11 @@ libxml2.")
;; are met (provided GNOME is installed of course).
"gdm_session_set_environment_variable (self, \"XDG_CONFIG_DIRS\",\n"
" \"/run/current-system/profile/etc/xdg\");\n"
+ ;; The session bus (which GDM will initialize from the this
+ ;; session environment) needs to know where to find the system
+ ;; service files.
+ "gdm_session_set_environment_variable (self, \"XDG_DATA_DIRS\",\n"
+ " \"/run/current-system/profile/share\");\n"
)))
;; Look for custom GDM conf in /run/current-system.
(substitute* '("common/gdm-settings-desktop-backend.c")
@@ -6435,15 +6446,16 @@ functionality and behavior.")
(define-public arc-theme
(package
(name "arc-theme")
- (version "20170302")
+ (version "20181022")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/horst3180/arc-theme"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NicoHood/arc-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0igxpngnkf1wpsg872a9jg3c9f5z8afm312yfbillz16mk8w39cw"))))
+ "08951dk1irfadwpr3p323a4fprmxg53rk2r2niwq3v62ryhi3663"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -6454,16 +6466,20 @@ functionality and behavior.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("gtk+" ,gtk+)))
+ ("glib" ,glib "bin") ; for glib-compile-resources
+ ("gnome-shell" ,gnome-shell)
+ ("gtk+" ,gtk+)
+ ("inkscape" ,inkscape)
+ ("optipng" ,optipng)
+ ("pkg-config" ,pkg-config)
+ ("sassc" ,sassc)))
(synopsis "A flat GTK+ theme with transparent elements")
(description "Arc is a flat theme with transparent elements for GTK 3, GTK
2, and GNOME Shell which supports GTK 3 and GTK 2 based desktop environments
like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(home-page "https://github.com/horst3180/arc-theme")
;; No "or later" language found.
- (license license:gpl3)))
+ (license license:gpl3+)))
(define-public faba-icon-theme
(package