summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 9b45e84559..f887f8eb30 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -142,14 +142,14 @@ translated messages from the catalogs. Nearly all GNU packages use Gettext.")
(define-public po4a
(package
(name "po4a")
- (version "0.47")
+ (version "0.53")
(source (origin
(method url-fetch)
- (uri (string-append "https://alioth.debian.org/frs/download.php"
- "/file/4142/po4a-" version ".tar.gz"))
+ (uri (string-append "https://github.com/mquinson/po4a/releases/download/v"
+ version "/po4a-" version ".tar.gz"))
(sha256
(base32
- "01vm0750aq0h2lphrflv3wq9gz7y0py8frglfpacn58ivyvy242h"))))
+ "033qrd37zjjzvjl6g55fvhlcrm7gynfx6rj76qpr2852dn0mw069"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -166,6 +166,14 @@ translated messages from the catalogs. Nearly all GNU packages use Gettext.")
(lambda _
(delete-file "t/20-sgml.t")
#t))
+ (add-before 'check 'disable-asciidoc-test
+ (lambda _
+ (delete-file "t/30-asciidoc.t")
+ #t))
+ (add-before 'check 'disable-yaml-test
+ (lambda _
+ (delete-file "t/32-yaml.t")
+ #t))
(add-after 'unpack 'fix-builder
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "Po4aBuilder.pm"