summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm127
1 files changed, 71 insertions, 56 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e5f8350f6a..b62d679a91 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
@@ -189,11 +189,13 @@ settings to tweak as well.")
(modules '((guix build utils)))
(snippet
;; Import cmath header for the std::pow function.
- '(for-each (lambda (file)
- (substitute* file
- (("#include <math.h>")
- "#include <cmath>")))
- (find-files "src")))))
+ '(begin
+ (for-each (lambda (file)
+ (substitute* file
+ (("#include <math.h>")
+ "#include <cmath>")))
+ (find-files "src"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
@@ -683,9 +685,11 @@ watch your CPU playing while enjoying a cup of tea!")
"151v6nign86m1a2vqz27krsccpc9m4d1jax4y43v2fa82wfj9qp0"))
(modules '((guix build utils)))
(snippet
- '(substitute* "src/version.c"
- (("__DATE__") "")
- (("__TIME__") "")))))
+ '(begin
+ (substitute* "src/version.c"
+ (("__DATE__") "")
+ (("__TIME__") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-cpu-opt")
@@ -897,7 +901,9 @@ can be explored and changed freely.")
(modules '((guix build utils)))
(snippet
;; Unbundle fonts.
- '(delete-file-recursively "fonts"))))
+ '(begin
+ (delete-file-recursively "fonts")
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("CC=gcc")
@@ -953,15 +959,15 @@ that beneath its ruins lay buried an ancient evil.")
;; In the future, if someone tries to make a graphical variant of
;; this package, they can deal with that mess themselves. :)
'(begin
- (for-each
- (lambda (subdir)
- (let ((lib-subdir (string-append "lib/" subdir)))
- (delete-file-recursively lib-subdir)))
- '("fonts" "icons" "sounds" "tiles"))
+ (for-each (lambda (subdir)
+ (let ((lib-subdir (string-append "lib/" subdir)))
+ (delete-file-recursively lib-subdir)))
+ '("fonts" "icons" "sounds" "tiles"))
(substitute* "lib/Makefile"
;; And don't try to invoke makefiles in the directories we removed
(("gamedata customize help screens fonts tiles sounds icons user")
- "gamedata customize help screens user"))))))
+ "gamedata customize help screens user"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no check target
@@ -1176,7 +1182,8 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(assoc-ref %build-inputs "bash")
(assoc-ref %build-inputs "engine")
(assoc-ref %build-inputs "data"))
- (chmod port #o777)))))
+ (chmod port #o777)))
+ #t))
#:modules ((guix build utils))))
(inputs `(("engine" ,freedink-engine)
("data" ,freedink-data)
@@ -1282,11 +1289,13 @@ destroy, the better your score. The person with the highest score wins.")
;; We do not provide `ncurses.h' within an `ncursesw'
;; sub-directory, so patch the source accordingly. See
;; <http://bugs.gnu.org/19018>.
- '(for-each (lambda (file)
- (substitute* file
- (("ncursesw/ncurses.h")
- "ncurses.h")))
- (find-files "." "configure$|\\.c$")))))
+ '(begin
+ (for-each (lambda (file)
+ (substitute* file
+ (("ncursesw/ncurses.h")
+ "ncurses.h")))
+ (find-files "." "configure$|\\.c$"))
+ #t))))
(build-system gnu-build-system)
(inputs `(("ncurses" ,ncurses)
("perl" ,perl)))
@@ -1433,10 +1442,11 @@ match, cannon keep, and grave-itation pit.")
"gzip")
"/bin")))
(setenv "PATH" path)
- (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (invoke tar "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append "minetest_game-" ,version))
(mkdir-p install-dir)
- (copy-recursively "." install-dir)))))
+ (copy-recursively "." install-dir)
+ #t))))
(synopsis "Main game data for the Minetest game engine")
(description
"Game data for the Minetest infinite-world block sandox game.")
@@ -1990,7 +2000,9 @@ world}, @uref{http://evolonline.org, Evol Online} and
(modules '((guix build utils)))
(snippet
;; The DOS port contains proprietary software.
- '(delete-file-recursively "os/dos"))))
+ '(begin
+ (delete-file-recursively "os/dos")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
@@ -2603,18 +2615,19 @@ Red Eclipse provides fast paced and accessible gameplay.")
(bin (string-append out "/bin"))
(doc (string-append out
"/share/doc/grue-hunter")))
- (begin
- (copy-file tarball "grue-hunter.tar.gz")
- (zero? (system* gzip "-d" "grue-hunter.tar.gz"))
- (zero? (system* tar "xvf" "grue-hunter.tar"))
-
- (mkdir-p bin)
- (copy-file "grue-hunter/gh.pl"
- (string-append bin "/grue-hunter"))
- (patch-shebang (string-append bin "/grue-hunter")
- (list perl))
-
- (install-file "grue-hunter/AGPLv3.txt" doc))))))
+ (copy-file tarball "grue-hunter.tar.gz")
+ (invoke gzip "-d" "grue-hunter.tar.gz")
+ (invoke tar "xvf" "grue-hunter.tar")
+
+ (mkdir-p bin)
+ (copy-file "grue-hunter/gh.pl"
+ (string-append bin "/grue-hunter"))
+ (patch-shebang (string-append bin "/grue-hunter")
+ (list perl))
+
+ (install-file "grue-hunter/AGPLv3.txt" doc)
+
+ #t))))
(inputs `(("perl" ,perl)
("tar" ,tar)
("gzip" ,gzip)
@@ -2840,7 +2853,8 @@ safety of the Chromium vessel.")
(substitute* "Makefile"
;; Do not rely on $(GPERF) being an absolute file name
(("\\[ -x \\$\\(GPERF\\) \\]")
- "$(GPERF) --version >/dev/null 2>&1"))))
+ "$(GPERF) --version >/dev/null 2>&1"))
+ #t))
(patches (search-patches "tuxpaint-stamps-path.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -2920,11 +2934,12 @@ your child be creative.")
(string-append
(assoc-ref %build-inputs "tar") "/bin" ":"
(assoc-ref %build-inputs "gzip") "/bin"))
- (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
+ (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append ,name "-" ,version))
(let ((dir (string-append %output "/share/tuxpaint/stamps")))
(mkdir-p dir)
- (copy-recursively "stamps" dir)))))
+ (copy-recursively "stamps" dir))
+ #t)))
(home-page (package-home-page tuxpaint))
(synopsis "Stamp images for Tux Paint")
(description
@@ -4055,14 +4070,13 @@ fight against their plot and save his fellow rabbits from slavery.")
(modules '((guix build utils)))
(snippet
#~(begin
- (for-each
- (lambda (name)
- (let* ((dir (string-append "binaries/data/mods/" name))
- (file (string-append dir "/" name ".zip"))
- (unzip #$(file-append unzip "/bin/unzip")))
- (system* unzip "-d" dir file)
- (delete-file file)))
- '("mod" "public"))
+ (for-each (lambda (name)
+ (let* ((dir (string-append "binaries/data/mods/" name))
+ (file (string-append dir "/" name ".zip"))
+ (unzip #$(file-append unzip "/bin/unzip")))
+ (invoke unzip "-d" dir file)
+ (delete-file file)))
+ '("mod" "public"))
#t))))
(build-system trivial-build-system)
(native-inputs `(("tar" ,tar)
@@ -4078,7 +4092,7 @@ fight against their plot and save his fellow rabbits from slavery.")
(xz-path (string-append (assoc-ref %build-inputs "xz") "/bin")))
(setenv "PATH" xz-path)
(mkdir out)
- (zero? (system* tar "xvf" source "-C" out "--strip=3"))))))
+ (invoke tar "xvf" source "-C" out "--strip=3")))))
(synopsis "Data files for 0ad")
(description "0ad-data provides the data files required by the game 0ad.")
(home-page "https://play0ad.com")
@@ -4297,10 +4311,12 @@ Crowther & Woods, its original authors, in 1995. It has been known as
"0v2qgdfpvdzd1bcbp9v8pfahj1bgczsq2d4xfhh5wg11jgjcwz03"))
(modules '((guix build utils)))
(snippet
- '(substitute* '("src/music.h" "src/tSDL.h")
- (("#elif defined(__FreeBSD__)" line)
- (string-append
- line " || defined(__GNUC__)"))))))
+ '(begin
+ (substitute* '("src/music.h" "src/tSDL.h")
+ (("#elif defined(__FreeBSD__)" line)
+ (string-append
+ line " || defined(__GNUC__)")))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("unzip" ,unzip)))
@@ -4640,8 +4656,6 @@ elements to achieve a simple goal in the most complex way possible.")
(string-append "PIONEER_DATA_DIR="
%output "/share/games/pioneer"))
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _ (zero? (system* "sh" "bootstrap"))))
(add-before 'bootstrap 'fix-lua-check
(lambda _
(substitute* "configure.ac"
@@ -4785,7 +4799,8 @@ You can save humanity and get programming skills!")
(delete-file-recursively "bzip2")
(delete-file-recursively "game-music-emu")
(delete-file-recursively "jpeg-6b")
- (delete-file-recursively "zlib")))))
+ (delete-file-recursively "zlib")
+ #t))))
(arguments
'(#:tests? #f
#:configure-flags