summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6fe44d90d1..cedf3573b6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1121,9 +1121,25 @@ later hand-tweaked with the gbdfed(1) editor:
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'install 'chdir
- (lambda _
- (chdir "Web")
+ (add-after 'install 'install-conf
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((conf-dir (string-append (assoc-ref outputs "out")
+ "/share/fontconfig/conf.avail")))
+ (mkdir-p conf-dir)
+ (call-with-output-file
+ (string-append conf-dir "/30-comic-neue.conf")
+ (lambda (port)
+ (format port "<?xml version=\"1.0\"?>
+<!DOCTYPE fontconfig SYSTEM \"fonts.dtd\">
+<fontconfig>
+ <!-- If Comic Sans is missing, use Comic Neue instead. -->
+ <alias>
+ <family>Comic Sans MS</family>
+ <prefer>
+ <family>Comic Neue</family>
+ </prefer>
+ </alias>
+</fontconfig>\n"))))
#t)))))
(home-page "http://www.comicneue.com/")
(synopsis "Font that fixes the shortcomings of Comic Sans")