summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 29c5c92766..e08b0c13db 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -45,22 +45,10 @@
(build-system gnu-build-system)
(inputs
(let ((bison-for-tests
- ;; Work around an incompatibility with Bison 3.0:
- ;; <http://lists.gnu.org/archive/html/bug-bison/2013-09/msg00014.html>.
(package
(inherit bison)
- (version "2.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://gnu/bison/"
- "bison-" version ".tar.xz"))
- (sha256
- (base32
- "1yx7isx67sdmyijvihgyra1f59fwdz7sqriginvavfj5yb5ss2dl"))))
-
- ;; Unlike Bison 3.0, this version did not need Flex for its
- ;; tests, so it allows us to break the cycle.
+ ;; Disable tests, since they require flex.
+ (arguments '(#:tests? #f))
(inputs (alist-delete "flex" (package-inputs bison))))))
`(("bison" ,bison-for-tests)
("indent" ,indent))))