summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c52c812f00..f944d25b60 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -755,3 +755,27 @@ Django projects, which allows association of a number of tags with any
(define-public python2-django-tagging
(package-with-python2 python-django-tagging))
+
+(define-public python-djangorestframework
+ (package
+ (name "python-djangorestframework")
+ (version "3.7.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "djangorestframework" version))
+ (sha256
+ (base32
+ "11qv117gqwswxjljs7wafxg1hyzzlx3qrviwlk9hw41bsbl997lz"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page "https://www.django-rest-framework.org")
+ (synopsis "Toolkit for building Web APIs with Django")
+ (description
+ "The Django REST framework is for building Web APIs with Django. It
+provides features like a web browseable API and authentication policies.")
+ (license license:bsd-2)))