summaryrefslogtreecommitdiff
path: root/gnu/packages/connman.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/connman.scm')
-rw-r--r--gnu/packages/connman.scm49
1 files changed, 47 insertions, 2 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 6b061db58a..0fced0be79 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -1,5 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Mathieu OTHACEHE <m.othacehe@gmail.com>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,7 +30,9 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages samba)
#:use-module (gnu packages tls)
@@ -50,7 +54,7 @@
(arguments
`(#:configure-flags
(list "--enable-nmcompat"
- ;; "--enable-polkit"
+ "--enable-polkit"
"--enable-openconnect"
"--enable-openvpn"
"--enable-vpnc"
@@ -71,7 +75,7 @@
("glib" ,glib)
("gnutls" ,gnutls)
("iptables" ,iptables)
- ;; ("polkit" ,polkit) ; pkg-config cannot find polkit.pc
+ ("polkit" ,polkit) ;so connman can be used by unprivileged users
("readline" ,readline)
;; These inputs are needed for connman to include the interface to
;; these technologies so IF they are installed they can be used.
@@ -120,9 +124,50 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(inputs
`(("efl" ,efl)
("python-2" ,python-2)
+ ("python2-dbus" ,python2-dbus)
("python2-efl" ,python2-efl)))
(home-page "https://www.enlightenment.org")
(synopsis "Connman User Interface written using the EFL")
(description
"An EFL user interface for the @code{connman} connection manager.")
(license lgpl3)))
+
+(define-public cmst
+ (package
+ (name "cmst")
+ (version "2016.10.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/andrew-bibb/cmst/releases/download/cmst-"
+ version "/cmst-" version ".tar.gz"))
+ (sha256
+ (base32 "1xpn4sqnxzpsjjwh9hva9sn55xlryiz2f2mwpyj2l31janj7a082"))))
+ (inputs
+ `(("qt" ,qt)))
+ (native-inputs
+ `(("qmake" ,qt)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero?
+ (system* "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out"))))))
+ (add-before 'install 'fix-Makefiles
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (find-files "." "Makefile")
+ (("INSTALL_ROOT)")
+ (string-append "INSTALL_ROOT)" out))
+ (("/usr/bin") "/bin"))))))))
+ (home-page "https://github.com/andrew-bibb/cmst")
+ (synopsis "Qt frontend for Connman")
+ (description
+ "Cmst is a Qt based frontend for the @code{connman} connection manager.
+This package also provides a systemtray icon.")
+ (license x11)))