summaryrefslogtreecommitdiff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index b56a081984..a10747ef38 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,7 +53,7 @@
(base32
"0ii73nsd3xzkhz6w1rnxwphl637j9w82xiy6apa9vin2isdynnmc"))))
(build-system gnu-build-system)
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Extended C++ template library")
(description
"ETL is a class and template library designed to add new datatypes and
@@ -130,7 +131,7 @@ C++ @dfn{Standard Template Library} (STL).")
("pango" ,pango)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation renderer")
(description
"Synfig is a vector-based 2D animation package. It is designed to be
@@ -180,7 +181,7 @@ for tweening, preventing the need to hand-draw each frame.")
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation package (GUI)")
(description
"Synfig is a vector-based 2D animation package. It is designed to
@@ -226,10 +227,10 @@ contains the graphical user interface for synfig.")
"\nLIBS +=" libsndfile
"/lib/libsndfile.so\n"
"win32 {"))))
- (zero? (system* "qmake"
- (string-append "DESTDIR="
- (assoc-ref outputs "out")
- "/bin")))))
+ (invoke "qmake"
+ (string-append "DESTDIR="
+ (assoc-ref outputs "out")
+ "/bin"))))
;; Ensure that all required Qt plugins are found at runtime.
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -248,7 +249,7 @@ contains the graphical user interface for synfig.")
("libsndfile" ,libsndfile)))
(native-inputs
`(("qttools" ,qttools)))
- (home-page "http://www.lostmarble.com/papagayo/")
+ (home-page "https://www.lostmarble.com/papagayo/")
(synopsis "Lip-syncing for animations")
(description
"Papagayo is a lip-syncing program designed to help you line up