summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 191afe7b08..e0ae3a96a2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5576,6 +5576,28 @@ support to both Ruby and JRuby. It uses @code{unf_ext} on CRuby and
(home-page "https://github.com/knu/ruby-unf")
(license license:bsd-2)))
+(define-public ruby-warden
+ (package
+ (name "ruby-warden")
+ (version "1.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "warden" version))
+ (sha256
+ (base32
+ "0va966lhpylcwbqb9n151kkihx30agh0a57mwjwdxyanll4s1q12"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs `(("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "Rack middleware that provides authentication for rack applications")
+ (description
+ "Rack middleware that provides authentication for rack applications")
+ (home-page "http://github.com/hassox/warden")
+ (license license:expat)))
+
(define-public ruby-webmock-2
(package
(name "ruby-webmock")