summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/enlightenment.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 8550a89640..a0bf841415 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -286,9 +286,10 @@ Libraries with some extra bells and whistles.")
(("/bin/mount") (string-append utils "/bin/mount"))
(("/bin/umount") (string-append utils "/bin/umount"))
(("/usr/bin/eject") (string-append utils "/bin/eject"))
- ; TODO: Replace suspend and hibernate also.
- (("/sbin/shutdown -h now") "/run/current-system/profile/sbin/halt")
- (("/sbin/shutdown -r now") "/run/current-system/profile/sbin/reboot"))
+ (("/etc/acpi/sleep.sh force") "/run/current-system/profile/bin/loginctl suspend")
+ (("/etc/acpi/hibernate.sh force") "/run/current-system/profile/bin/loginctl hibernate")
+ (("/sbin/shutdown -h now") "/run/current-system/profile/bin/loginctl poweroff now")
+ (("/sbin/shutdown -r now") "/run/current-system/profile/bin/loginctl reboot now"))
#t))))))
(native-inputs
`(("gettext" ,gettext-minimal)