summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ed1868e578..3ecdc1b7e3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15184,3 +15184,25 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "coala Dependency Management")
(description "coala Dependency Management")
(license #f)))
+
+(define-public python-colorlog
+ (package
+ (name "python-colorlog")
+ (version "3.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colorlog" version))
+ (sha256
+ (base32
+ "0i21sd6pggr2gqza41vyq2rqyb552wf5iwl4bc16i7kqislbd53z"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)))
+ (home-page
+ "https://github.com/borntyping/python-colorlog")
+ (synopsis "Log formatting with colors!")
+ (description "Log formatting with colors!")
+ (license #f)))