summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/dico.scm14
-rw-r--r--gnu/packages/patches/dico-idxgcide-bug.patch21
-rw-r--r--gnu/packages/patches/dico-libtool-deterministic.patch15
4 files changed, 7 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d4a09ef1a6..a9faffffb9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -471,8 +471,6 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-helper-search-path.patch \
%D%/packages/patches/devil-CVE-2009-3994.patch \
%D%/packages/patches/devil-fix-libpng.patch \
- %D%/packages/patches/dico-idxgcide-bug.patch \
- %D%/packages/patches/dico-libtool-deterministic.patch \
%D%/packages/patches/diffutils-gets-undeclared.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/doc++-include-directives.patch \
diff --git a/gnu/packages/dico.scm b/gnu/packages/dico.scm
index 87062f94dc..16ab343cb0 100644
--- a/gnu/packages/dico.scm
+++ b/gnu/packages/dico.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages readline)
#:use-module (gnu packages m4)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages guile)
#:use-module (gnu packages python)
#:use-module (gnu packages pcre)
@@ -35,17 +37,14 @@
(define-public dico
(package
(name "dico")
- (version "2.2")
+ (version "2.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/dico/dico-"
version ".tar.xz"))
(sha256
(base32
- "04pjks075x20d19l623mj50bw64g8i41s63z4kzzqcbg9qg96x64"))
- (patches (search-patches "cpio-gets-undeclared.patch"
- "dico-libtool-deterministic.patch"
- "dico-idxgcide-bug.patch"))))
+ "13by0zimx90v2j8v7n4k9y3xwmh4q9jdc2f4f8yjs3x7f5bzm2pk"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
@@ -62,10 +61,11 @@
(inputs
`(("m4" ,m4) ;used at run time
("pcre" ,pcre)
- ;; ("python" ,python-2)
+ ("python" ,python-2)
("guile" ,guile-2.0)
("gsasl" ,gsasl)
- ("readline" ,readline-6.2)
+ ("groff" ,groff)
+ ("readline" ,readline)
("zlib" ,zlib)
;; ("wordnet" ,wordnet) ;FIXME: link failure
("libltdl" ,libltdl)))
diff --git a/gnu/packages/patches/dico-idxgcide-bug.patch b/gnu/packages/patches/dico-idxgcide-bug.patch
deleted file mode 100644
index 28cc8a6a08..0000000000
--- a/gnu/packages/patches/dico-idxgcide-bug.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Reported at <http://mail.gnu.org.ua/archives/bug-dico/2016-07/msg00000.html>.
-Patch the .c file to avoid depending on Flex.
-
-commit 4599abbda3b5979367138ea098e435c919fe93fc
-Author: Sergey Poznyakoff <gray@gnu.org>
-Date: Thu Jul 28 14:09:58 2016 +0300
-
- Bugfix
-
- * modules/gcide/idxgcide.l (main): Initialize ipg_header.
-
---- dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:07.823587004 +0200
-+++ dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:09.435600549 +0200
-@@ -2497,6 +2497,7 @@ main(int argc, char **argv)
- dico_log(L_ERR, 0, _("not enough memory"));
- exit(EX_UNAVAILABLE);
- }
-+ idx_page->ipg_header.hdr.phdr_numentries = 0;
- idx_page->ipg_header.hdr.phdr_text_offset = idx_header.ihdr_pagesize / 2;
-
- idx_header.ihdr_maxpageref = idx_header.ihdr_pagesize / 2 /
diff --git a/gnu/packages/patches/dico-libtool-deterministic.patch b/gnu/packages/patches/dico-libtool-deterministic.patch
deleted file mode 100644
index 957fc79786..0000000000
--- a/gnu/packages/patches/dico-libtool-deterministic.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Dico 2.2 uses an old Libtool (2.2.7a) that did not sort the output
-of 'find', thereby leading to non-deterministic file name ordering
-in the arguments passed to 'ar rcu' for libdico.a & co.
-
---- dico-2.2/build-aux/ltmain.sh 1970-01-01 01:00:00.000000000 +0100
-+++ dico-2.2/build-aux/ltmain.sh 2015-11-25 09:39:30.826169050 +0100
-@@ -2926,7 +2926,7 @@ func_extract_archives ()
- func_extract_an_archive "$my_xdir" "$my_xabs"
- ;;
- esac
-- my_oldobjs="$my_oldobjs "`find $my_xdir -name \*.$objext -print -o -name \*.lo -print | $NL2SP`
-+ my_oldobjs="$my_oldobjs "`find $my_xdir -name \*.$objext -print -o -name \*.lo -print | sort | $NL2SP`
- done
-
- func_extract_archives_result="$my_oldobjs"