summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--etc/completion/bash/guix-daemon30
2 files changed, 33 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a19b6b9e..ab145065d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,7 @@
# Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
# Copyright © 2018 Nils Gillmann <ng0@n0.is>
# Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -454,7 +455,8 @@ dist_pkgdata_DATA = \
berlin.guixsd.org.pub
# Bash completion file.
-dist_bashcompletion_DATA = etc/completion/bash/guix
+dist_bashcompletion_DATA = etc/completion/bash/guix \
+ etc/completion/bash/guix-daemon
# Zsh completion file.
dist_zshcompletion_DATA = etc/completion/zsh/_guix
diff --git a/etc/completion/bash/guix-daemon b/etc/completion/bash/guix-daemon
new file mode 100644
index 0000000000..997c142c7e
--- /dev/null
+++ b/etc/completion/bash/guix-daemon
@@ -0,0 +1,30 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+# Bash completion for guix-daemon command.
+
+_guix_daemon_complete ()
+{
+ local options="$(${COMP_WORDS[0]} --help 2> /dev/null \
+ | grep '^ \+-' \
+ | sed -e's/^.*--\([a-zA-Z0-9_-]\+\)\(=\?\).*/--\1\2/g')"
+ compopt -o nospace
+ COMPREPLY=($(compgen -W "$options" -- "${COMP_WORDS[${#COMP_WORDS[*]} - 1]}"))
+}
+
+complete -F _guix_daemon_complete guix-daemon