summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/services/version-control.scm11
-rw-r--r--po/packages/POTFILES.in1
2 files changed, 10 insertions, 2 deletions
diff --git a/gnu/services/version-control.scm b/gnu/services/version-control.scm
index 388038e7bc..fce2ce1c25 100644
--- a/gnu/services/version-control.scm
+++ b/gnu/services/version-control.scm
@@ -156,7 +156,11 @@
(service-extension account-service-type
(const %git-daemon-accounts))
(service-extension activation-service-type
- git-daemon-activation)))))
+ git-daemon-activation)))
+ (description
+ "Expose Git respositories over the insecure @code{git://} TCP-based
+protocol.")
+ (default-value (git-daemon-configuration))))
(define* (git-daemon-service #:key (config (git-daemon-configuration)))
"Return a service that runs @command{git daemon}, a simple TCP server to
@@ -259,7 +263,10 @@ access to exported repositories under @file{/srv/git}."
cgit-activation)
(service-extension nginx-service-type
cgit-configuration-nginx-config)))
- (default-value (cgit-configuration))))
+ (default-value (cgit-configuration))
+ (description
+ "Run the Cgit web interface, which allows users to browse Git
+repositories.")))
;;;
diff --git a/po/packages/POTFILES.in b/po/packages/POTFILES.in
index cfc542f50e..83a13c1dab 100644
--- a/po/packages/POTFILES.in
+++ b/po/packages/POTFILES.in
@@ -59,3 +59,4 @@ gnu/packages/wordnet.scm
gnu/packages/xiph.scm
gnu/services/base.scm
gnu/services/networking.scm
+gnu/services/version-control.scm