summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 78c5c5cb5a..2755dc2912 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15661,3 +15661,26 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"A library to produce ansi color output and colored highlighting and diffing")
(license #f)))
+
+(define-public python-vim-vint
+ (package
+ (name "python-vim-vint")
+ (version "0.3.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vim-vint" version))
+ (sha256
+ (base32
+ "0w038bgic7rdim60rhwrx3gwj33lgmhad8shpvcl2iy6fy8rpp7y"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-ansicolor" ,python-ansicolor)
+ ("python-chardet" ,python-chardet)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/Kuniwak/vint")
+ (synopsis "Lint tool for Vim script Language")
+ (description "Lint tool for Vim script Language")
+ (license #f)))