summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/base.scm55
-rw-r--r--gnu/packages/calendar.scm26
-rw-r--r--gnu/packages/certs.scm11
-rw-r--r--gnu/packages/gl.scm6
-rw-r--r--gnu/packages/gnome.scm14
-rw-r--r--gnu/packages/gnuzilla.scm14
-rw-r--r--gnu/packages/gtk.scm11
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/ninja.scm2
-rw-r--r--gnu/packages/patches/gtk2-fix-failing-test.patch39
-rw-r--r--gnu/packages/patches/json-glib-fix-tests-32bit.patch174
-rw-r--r--gnu/packages/pciutils.scm5
-rw-r--r--gnu/packages/pulseaudio.scm13
-rw-r--r--gnu/packages/python.scm14
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/web.scm7
-rw-r--r--gnu/packages/xdisorg.scm4
-rw-r--r--gnu/packages/xorg.scm4
19 files changed, 295 insertions, 114 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3d0bd38e50..c3f28da6dd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -745,7 +745,6 @@ dist_patch_DATA = \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
%D%/packages/patches/gtk2-theme-paths.patch \
- %D%/packages/patches/gtk2-fix-failing-test.patch \
%D%/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
%D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
@@ -789,6 +788,7 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
%D%/packages/patches/jemalloc-arm-address-bits.patch \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
+ %D%/packages/patches/json-glib-fix-tests-32bit.patch \
%D%/packages/patches/jq-CVE-2015-8863.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/khmer-use-libraries.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b2c1d232fb..b6c6dabae1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1081,7 +1081,7 @@ command.")
(define-public tzdata
(package
(name "tzdata")
- (version "2017c")
+ (version "2018c")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1089,7 +1089,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "02yrrfj0p7ar885ja41ylijzbr8wc6kz6kzlw8c670i9m693ym6n"))))
+ "1xik57rdi7kqa0wb5jbz7vyjyxpr88lw1g4kscj0ylpgnzjc6998"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -1097,10 +1097,8 @@ command.")
(tmp (getenv "TMPDIR")))
(list (string-append "TOPDIR=" out)
(string-append "TZDIR=" out "/share/zoneinfo")
-
- ;; Discard zic, dump, and tzselect, already
- ;; provided by glibc.
- (string-append "ETCDIR=" tmp "/etc")
+ (string-append "TZDEFAULT=" out
+ "/share/zoneinfo/localtime")
;; Likewise for the C library routines.
(string-append "LIBDIR=" tmp "/lib")
@@ -1121,6 +1119,9 @@ command.")
(lambda* (#:key outputs #:allow-other-keys)
;; Move data in the right place.
(let ((out (assoc-ref outputs "out")))
+ ;; Discard zic, dump, and tzselect, already
+ ;; provided by glibc.
+ (delete-file-recursively (string-append out "/usr"))
(symlink (string-append out "/share/zoneinfo")
(string-append out "/share/zoneinfo/posix"))
(delete-file-recursively
@@ -1137,7 +1138,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "1dvrq0b2hz7cjqdyd7x21wpy4qcng3rvysr61ij0c2g64fyb9s41"))))))
+ "0rg6s1vlgwd8sjhla55hx2h5m2xbx0shm347pkbg4vsaz707zyii"))))))
(home-page "https://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)
@@ -1163,6 +1164,45 @@ and daylight-saving rules.")
(sha256
(base32
"02yrrfj0p7ar885ja41ylijzbr8wc6kz6kzlw8c670i9m693ym6n"))))
+ (arguments
+ '(#:tests? #f
+ #:make-flags (let ((out (assoc-ref %outputs "out"))
+ (tmp (getenv "TMPDIR")))
+ (list (string-append "TOPDIR=" out)
+ (string-append "TZDIR=" out "/share/zoneinfo")
+
+ ;; Discard zic, dump, and tzselect, already
+ ;; provided by glibc.
+ (string-append "ETCDIR=" tmp "/etc")
+
+ ;; Likewise for the C library routines.
+ (string-append "LIBDIR=" tmp "/lib")
+ (string-append "MANDIR=" tmp "/man")
+
+ "AWK=awk"
+ "CC=gcc"))
+ #:modules ((guix build utils)
+ (guix build gnu-build-system)
+ (srfi srfi-1))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source inputs #:allow-other-keys)
+ (and (zero? (system* "tar" "xvf" source))
+ (zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode"))))))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move data in the right place.
+ (let ((out (assoc-ref outputs "out")))
+ (symlink (string-append out "/share/zoneinfo")
+ (string-append out "/share/zoneinfo/posix"))
+ (delete-file-recursively
+ (string-append out "/share/zoneinfo-posix"))
+ (copy-recursively (string-append out "/share/zoneinfo-leaps")
+ (string-append out "/share/zoneinfo/right"))
+ (delete-file-recursively
+ (string-append out "/share/zoneinfo-leaps")))))
+ (delete 'configure))))
(inputs `(("tzcode" ,(origin
(method url-fetch)
(uri (string-append
@@ -1172,7 +1212,6 @@ and daylight-saving rules.")
(base32
"1dvrq0b2hz7cjqdyd7x21wpy4qcng3rvysr61ij0c2g64fyb9s41")))))))))
-
(define-public libiconv
(package
(name "libiconv")
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 44bf05a9bb..474c1758cf 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -35,16 +35,19 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages dav)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages time)
+ #:use-module (gnu packages xml)
#:use-module (srfi srfi-26))
(define-public libical
(package
(name "libical")
- (version "2.0.0")
+ (version "3.0.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -52,15 +55,18 @@
version "/libical-" version ".tar.gz"))
(sha256
(base32
- "1njn2kr0rrjqv5g3hdhpdzrhankyj4fl1bgn76z3g4n1b7vi2k35"))))
+ "03k45dg79bf8lgymn94z2in1c3926v93h76xsap1svln63b3zg0c"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; test suite appears broken
+ #:configure-flags '("-DSHARED_ONLY=true")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
- (lambda _
- (let ((tzdata (assoc-ref %build-inputs "tzdata")))
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; FIXME: This should be patched to use TZDIR so we can drop
+ ;; the tzdata dependency.
+ (let ((tzdata (assoc-ref inputs "tzdata")))
(substitute* "src/libical/icaltz-util.c"
(("\\\"/usr/share/zoneinfo\\\",")
(string-append "\"" tzdata "/share/zoneinfo\""))
@@ -69,16 +75,22 @@
(("\\\"/usr/share/lib/zoneinfo\\\"") "")))
#t)))))
(native-inputs
- `(("perl" ,perl)))
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("icu4c" ,icu4c)
+ `(("glib" ,glib)
+ ("libxml2" ,libxml2)
("tzdata" ,tzdata)))
+ (propagated-inputs
+ ;; In Requires.private of libical.pc.
+ `(("icu4c" ,icu4c)))
(home-page "https://libical.github.io/libical/")
(synopsis "iCalendar protocols and data formats implementation")
(description
"Libical is an implementation of the iCalendar protocols and protocol
data units.")
- (license license:lgpl2.1)))
+ ;; Can be used with either license. See COPYING.
+ (license (list license:lgpl2.1 license:mpl2.0))))
(define-public khal
(package
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 0f2f2d25ba..e016d9f2ad 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -102,8 +102,10 @@
(srfi srfi-26)
(ice-9 regex))
#:phases
- (alist-cons-after
- 'unpack 'install
+ (modify-phases
+ (map (cut assq <> %standard-phases)
+ '(set-paths install-locale unpack))
+ (add-after 'unpack 'install
(lambda _
(let ((certsdir (string-append %output "/etc/ssl/certs/"))
(trusted-rx (make-regexp "^# openssl-trust=[a-zA-Z]"
@@ -131,10 +133,9 @@
;; "Usage error; try -help."
;; This looks like a bug in openssl-1.0.2, but we can also
;; switch into the target directory.
- (system* "c_rehash" "."))))
+ (invoke "c_rehash" "."))
+ #t))))))
- (map (cut assq <> %standard-phases)
- '(set-paths install-locale unpack)))))
(synopsis "CA certificates from Mozilla")
(description
"This package provides certificates for Certification Authorities (CA)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 0e416a9efd..6ce7fbc9b8 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -222,7 +222,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "17.3.1")
+ (version "17.3.5")
(source
(origin
(method url-fetch)
@@ -234,7 +234,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1h94m2nkxa1y4n415d5idk2x2lkgbvjcikv6r2r6yn4ak7h0grls"))
+ "0slksyk2b3j74w6h6sv4kgnblbkmayqwb08lbhhf0wdaiby2i4pb"))
(patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"
"mesa-skip-disk-cache-test.patch"))))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6f7e9e281..c876dbb6a9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1157,7 +1157,7 @@ XML/CSS rendering engine.")
(define-public libgsf
(package
(name "libgsf")
- (version "1.14.41")
+ (version "1.14.42")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1165,7 +1165,7 @@ XML/CSS rendering engine.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1lq87wnrsjbjafpk3c8xwd56gqx319fhck9xkg2da88hd9c9h2qm"))))
+ "1hhdz0ymda26q6bl5ygickkgrh998lxqq4z9i8dzpcvqna3zpzr9"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -2265,18 +2265,20 @@ configuration storage systems.")
(define-public json-glib
(package
(name "json-glib")
- (version "1.2.8")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "json-glib-fix-tests-32bit.patch"))
(sha256
(base32
- "02pl0wl3mf47c038bgv2r4pa6pr6y3shjhxn1l7s3rrrgl1sjmgx"))))
- (build-system gnu-build-system)
+ "1j3dd2xj1l9fi12m1gpmfgf5p4c1w0i970m6k62k3is98yj0jxrd"))))
+ (build-system meson-build-system)
(native-inputs
- `(("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
+ `(("gettext" ,gettext-minimal)
+ ("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)))
(propagated-inputs
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 8d9573fb81..66b5383868 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -250,7 +250,7 @@ in C/C++.")
(define-public nspr
(package
(name "nspr")
- (version "4.17")
+ (version "4.18")
(source (origin
(method url-fetch)
(uri (string-append
@@ -258,7 +258,7 @@ in C/C++.")
version "/src/nspr-" version ".tar.gz"))
(sha256
(base32
- "158hdn285dsb5rys8wl1wi32dd1axwhqq0r8fwny4aj157m0l2jr"))))
+ "0d7vr3wrgp73qbywrvdkikk8vq1s1n9vhf62db80g1zqkg05g5mq"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)))
@@ -268,6 +268,10 @@ in C/C++.")
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
+ ;; Use fixed timestamps for reproducibility.
+ #:make-flags '("SH_DATE='1970-01-01 00:00:01'"
+ ;; This is epoch 1 in microseconds.
+ "SH_NOW=100000")
#:phases (modify-phases %standard-phases
(add-before 'configure 'chdir
(lambda _ (chdir "nspr") #t)))))
@@ -282,7 +286,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.34.1")
+ (version "3.35")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -293,7 +297,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "186x33wsk4mzjz7dzbn8p0py9a0nzkgzpfkdv4rlyy5gghv5vhd3"))
+ "1ypn68z9ncbbshi3184ywrhx5i846lyd72gps1grzqzdkgh7s4pl"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
"nss-increase-test-timeout.patch"))))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ceb3f4dc4e..60f2013614 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -593,7 +593,7 @@ is part of the GNOME accessibility project.")
(define-public gtk+-2
(package
(name "gtk+")
- (version "2.24.31")
+ (version "2.24.32")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -601,11 +601,10 @@ is part of the GNOME accessibility project.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0n26jm09n03nqbd00d2ij63xrby3vik56sk5yj6w1vy768kr5hb8"))
+ "0bjq7ja9gwcv6n5q4qkvdjjx40wsdiikksz1zqxvxsm5vlyskj5n"))
(patches (search-patches "gtk2-respect-GUIX_GTK2_PATH.patch"
"gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch"
- "gtk2-theme-paths.patch"
- "gtk2-fix-failing-test.patch"))))
+ "gtk2-theme-paths.patch"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -659,7 +658,7 @@ application suites.")
(name "gtk+")
;; NOTE: When updating the version of 'gtk+', the hash of 'mate-themes' in
;; mate.scm will also need to be updated.
- (version "3.22.26")
+ (version "3.22.28")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -667,7 +666,7 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0rxrsh6bcp13hihxxs8f0m9xwniby4lmfi7y5mp9fhg5439z1vk1"))
+ "07syy63d2q12b7mkbhqpirq270365fsql5l9qsrdgzlc04mn36fj"))
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(outputs '("out" "bin" "doc"))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 420bdf5a47..c33b473ca9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2991,7 +2991,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
- (version "5.47")
+ (version "5.48")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2999,7 +2999,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
version ".tar.xz"))
(sha256
(base32
- "1j22hfjz0fp4pgclgz9mfcwjbr4wqgah3gd2qhfg4r6msmybyxfg"))))
+ "140fjyxa2q4y35d9n52vki649jzb094pf71hxkkvlrpgf8q75a5r"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/ninja.scm b/gnu/packages/ninja.scm
index adb236484f..5a168a6ada 100644
--- a/gnu/packages/ninja.scm
+++ b/gnu/packages/ninja.scm
@@ -48,6 +48,8 @@
(lambda _
(substitute* "src/subprocess-posix.cc"
(("/bin/sh") (which "sh")))
+ (substitute* "src/subprocess_test.cc"
+ (("/bin/echo") (which "echo")))
#t))
(replace 'build
(lambda _
diff --git a/gnu/packages/patches/gtk2-fix-failing-test.patch b/gnu/packages/patches/gtk2-fix-failing-test.patch
deleted file mode 100644
index 721dc012c7..0000000000
--- a/gnu/packages/patches/gtk2-fix-failing-test.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 12d8b4e8f2f9c9a7707d1d3fccba382732212e3c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= <boskovits@gmail.com>
-Date: Tue, 5 Dec 2017 20:06:36 +0100
-Subject: [PATCH] Fix test failing on new GLib versions.
-
-This test fails on newer GLib version, because GLib exports a new public marshaller.
-The additional symbol making the test fail is:
-g_cclosure_marshal_BOOLEAN__BOXED_BOXED
-
-The fix makes the test ignore non-gtk related abi.
-This ensures if future marshallers are added to glib those will not pose a problem.
-
-The fix also ensures that the test still checks the gtk abi for identity, and
-that the library provides a superset of the required abi.
-
-Upstream reponse to this problem was:
-
-GLib added a new marshaller in its public API
-And the `abicheck.sh`in GTK+ 2.24 hasn't been updated because GTK+ 2.24 is in deep
-maintenance mode and very few people test it against newer versions of GLib
-
----
- gtk/abicheck.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gtk/abicheck.sh b/gtk/abicheck.sh
-index 0d033fb..53b7bfe 100755
---- a/gtk/abicheck.sh
-+++ b/gtk/abicheck.sh
-@@ -1,5 +1,5 @@
- #! /bin/sh
-
- cpp -DINCLUDE_VARIABLES -P -DG_OS_UNIX -DGTK_WINDOWING_X11 -DALL_FILES ${srcdir:-.}/gtk.symbols | sed -e '/^$/d' -e 's/ G_GNUC.*$//' -e 's/ PRIVATE//' | sort > expected-abi
--nm -D -g --defined-only .libs/libgtk-x11-2.0.so | cut -d ' ' -f 3 | egrep -v '^(__bss_start|_edata|_end)' | sort > actual-abi
-+nm -D -g --defined-only .libs/libgtk-x11-2.0.so | cut -d ' ' -f 3 | egrep -v '^(__bss_start|_edata|_end)' | egrep '^gtk_' | sort > actual-abi
- diff -u expected-abi actual-abi && rm -f expected-abi actual-abi
---
-2.15.0
-
diff --git a/gnu/packages/patches/json-glib-fix-tests-32bit.patch b/gnu/packages/patches/json-glib-fix-tests-32bit.patch
new file mode 100644
index 0000000000..77ea134915
--- /dev/null
+++ b/gnu/packages/patches/json-glib-fix-tests-32bit.patch
@@ -0,0 +1,174 @@
+Fix floating point issues on 32-bit platforms:
+
+https://gitlab.gnome.org/GNOME/json-glib/issues/27
+
+This is an amalgamation of the following upstream commits:
+https://gitlab.gnome.org/GNOME/json-glib/commit/70e2648e02232c1a439a7418388f18fee9afb3fe
+https://gitlab.gnome.org/GNOME/json-glib/commit/675e27505776a1d77fa1ffd1974284890caec1f4
+
+diff --git a/json-glib/tests/json-test-utils.h b/json-glib/tests/json-test-utils.h
+new file mode 100644
+index 0000000..83a02c6
+--- /dev/null
++++ b/json-glib/tests/json-test-utils.h
+@@ -0,0 +1,21 @@
++#include <string.h>
++#include <math.h>
++#include <float.h>
++#include <glib.h>
++#include <json-glib/json-glib.h>
++
++#define json_fuzzy_equals(n1,n2,epsilon) \
++ (((n1) > (n2) ? ((n1) - (n2)) : ((n2) - (n1))) < (epsilon))
++
++#define json_assert_fuzzy_equals(n1,n2,epsilon) \
++ G_STMT_START { \
++ double __n1 = (n1), __n2 = (n2), __epsilon = (epsilon); \
++ if (json_fuzzy_equals (__n1, __n2, __epsilon)) ; else { \
++ g_assertion_message_cmpnum (G_LOG_DOMAIN, __FILE__, __LINE__, G_STRFUNC, \
++ #n1 " == " #n2 " (+/- " #epsilon ")", \
++ __n1, "==", __n2, 'f'); \
++ } \
++ } G_STMT_END
++
++#define json_assert_almost_equals(n1,n2) \
++ json_assert_fuzzy_equals (n1, n2, DBL_EPSILON)
+diff --git a/json-glib/tests/array.c b/json-glib/tests/array.c
+index 98afeab..426cd72 100644
+--- a/json-glib/tests/array.c
++++ b/json-glib/tests/array.c
+@@ -1,9 +1,4 @@
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <string.h>
+-
+-#include <glib.h>
+-#include <json-glib/json-glib.h>
++#include "json-test-utils.h"
+
+ static void
+ test_empty_array (void)
+@@ -37,7 +32,7 @@ test_add_element (void)
+
+ json_array_add_double_element (array, 3.14);
+ g_assert_cmpint (json_array_get_length (array), ==, 3);
+- g_assert_cmpfloat (json_array_get_double_element (array, 2), ==, 3.14);
++ json_assert_fuzzy_equals (json_array_get_double_element (array, 2), 3.14, 0.001);
+
+ json_array_add_boolean_element (array, TRUE);
+ g_assert_cmpint (json_array_get_length (array), ==, 4);
+diff --git a/json-glib/tests/node.c b/json-glib/tests/node.c
+index 23bda63..80beb78 100644
+--- a/json-glib/tests/node.c
++++ b/json-glib/tests/node.c
+@@ -1,6 +1,4 @@
+-#include <glib.h>
+-#include <json-glib/json-glib.h>
+-#include <string.h>
++#include "json-test-utils.h"
+
+ static void
+ test_init_int (void)
+@@ -19,7 +17,7 @@ test_init_double (void)
+ JsonNode *node = json_node_new (JSON_NODE_VALUE);
+
+ json_node_set_double (node, 3.14159);
+- g_assert_cmpfloat (json_node_get_double (node), ==, 3.14159);
++ json_assert_fuzzy_equals (json_node_get_double (node), 3.14159, 0.00001);
+
+ json_node_free (node);
+ }
+@@ -119,13 +117,13 @@ test_get_int (void)
+
+ json_node_set_int (node, 0);
+ g_assert_cmpint (json_node_get_int (node), ==, 0);
+- g_assert_cmpfloat (json_node_get_double (node), ==, 0.0);
++ json_assert_almost_equals (json_node_get_double (node), 0.0);
+ g_assert (!json_node_get_boolean (node));
+ g_assert (!json_node_is_null (node));
+
+ json_node_set_int (node, 42);
+ g_assert_cmpint (json_node_get_int (node), ==, 42);
+- g_assert_cmpfloat (json_node_get_double (node), ==, 42.0);
++ json_assert_almost_equals (json_node_get_double (node), 42.0);
+ g_assert (json_node_get_boolean (node));
+ g_assert (!json_node_is_null (node));
+
+@@ -138,7 +136,7 @@ test_get_double (void)
+ JsonNode *node = json_node_new (JSON_NODE_VALUE);
+
+ json_node_set_double (node, 3.14);
+- g_assert_cmpfloat (json_node_get_double (node), ==, 3.14);
++ json_assert_fuzzy_equals (json_node_get_double (node), 3.14, 0.001);
+ g_assert_cmpint (json_node_get_int (node), ==, 3);
+ g_assert (json_node_get_boolean (node));
+
+@@ -232,9 +230,9 @@ test_gvalue_autopromotion (void)
+ g_print ("Expecting a gdouble, got a %s\n", g_type_name (G_VALUE_TYPE (&check)));
+
+ g_assert_cmpint (G_VALUE_TYPE (&check), ==, G_TYPE_DOUBLE);
+- g_assert_cmpfloat ((float) g_value_get_double (&check), ==, 3.14159f);
++ json_assert_fuzzy_equals (g_value_get_double (&check), 3.14159, 0.00001);
+ g_assert_cmpint (G_VALUE_TYPE (&value), !=, G_VALUE_TYPE (&check));
+- g_assert_cmpfloat ((gdouble) g_value_get_float (&value), ==, g_value_get_double (&check));
++ json_assert_almost_equals (g_value_get_float (&value), g_value_get_double (&check));
+
+ g_value_unset (&value);
+ g_value_unset (&check);
+diff --git a/json-glib/tests/parser.c b/json-glib/tests/parser.c
+index f71584a..8c52a1d 100644
+--- a/json-glib/tests/parser.c
++++ b/json-glib/tests/parser.c
+@@ -1,11 +1,5 @@
+-#include "config.h"
+-
++#include "json-test-utils.h"
+ #include <stdlib.h>
+-#include <stdio.h>
+-
+-#include <glib.h>
+-
+-#include <json-glib/json-glib.h>
+
+ static const gchar *test_empty_string = "";
+ static const gchar *test_empty_array_string = "[ ]";
+@@ -38,13 +32,13 @@ verify_string_value (JsonNode *node)
+ static void
+ verify_double_value (JsonNode *node)
+ {
+- g_assert_cmpfloat (10.2e3, ==, json_node_get_double (node));
++ json_assert_fuzzy_equals (10.2e3, json_node_get_double (node), 0.1);
+ }
+
+ static void
+ verify_negative_double_value (JsonNode *node)
+ {
+- g_assert_cmpfloat (-3.14, ==, json_node_get_double (node));
++ json_assert_fuzzy_equals (-3.14, json_node_get_double (node), 0.01);
+ }
+
+ static const struct {
+diff --git a/json-glib/tests/reader.c b/json-glib/tests/reader.c
+index 43a6aac..9bab312 100644
+--- a/json-glib/tests/reader.c
++++ b/json-glib/tests/reader.c
+@@ -1,9 +1,4 @@
+-#include <stdlib.h>
+-#include <stdio.h>
+-
+-#include <glib.h>
+-
+-#include <json-glib/json-glib.h>
++#include "json-test-utils.h"
+
+ static const gchar *test_base_array_data =
+ "[ 0, true, null, \"foo\", 3.14, [ false ], { \"bar\" : 42 } ]";
+@@ -78,7 +73,7 @@ test_base_object (void)
+ g_assert (json_reader_get_error (reader) == NULL);
+
+ json_reader_read_member (reader, "double");
+- g_assert_cmpfloat (json_reader_get_double_value (reader), ==, 42.47);
++ json_assert_fuzzy_equals (json_reader_get_double_value (reader), 42.47, 0.01);
+ json_reader_end_element (reader);
+
+ g_object_unref (reader);
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index e052b20776..e77aa3f288 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,7 @@
(define-public pciutils
(package
(name "pciutils")
- (version "3.5.5")
+ (version "3.5.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -38,7 +39,7 @@
version ".tar.xz"))
(sha256
(base32
- "1x9rb5y82rzg8b67lh42yy9ag9xr7kzibz566lffd41g37xghqhx"))))
+ "08dvsk1b5m1r7qqzsm849h4glq67mngf8zw7bg0102ff1jwywipk"))))
(build-system gnu-build-system)
(arguments
'(#:phases
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 903b22529d..2721c231c3 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -47,7 +47,6 @@
(define-public libsndfile
(package
(name "libsndfile")
- (replacement libsndfile/fixed)
(version "1.0.28")
(source (origin
(method url-fetch)
@@ -55,7 +54,8 @@
version ".tar.gz"))
(patches (search-patches "libsndfile-armhf-type-checks.patch"
"libsndfile-CVE-2017-8361-8363-8365.patch"
- "libsndfile-CVE-2017-8362.patch"))
+ "libsndfile-CVE-2017-8362.patch"
+ "libsndfile-CVE-2017-12562.patch"))
(sha256
(base32
"1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))
@@ -81,15 +81,6 @@ SPARC. Hopefully the design of the library will also make it easy to extend
for reading and writing new sound file formats.")
(license l:gpl2+)))
-(define libsndfile/fixed
- (package
- (inherit libsndfile)
- (source (origin
- (inherit (package-source libsndfile))
- (patches (append
- (origin-patches (package-source libsndfile))
- (search-patches "libsndfile-CVE-2017-12562.patch")))))))
-
(define-public libsamplerate
(package
(name "libsamplerate") ; aka. Secret Rabbit Code (SRC)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 69101c78b9..ce56e72847 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5464,7 +5464,7 @@ complexity of Python source code.")
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
- ("python2-enum" ,python2-enum)
+ ("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs base))))))
;; python-hacking requires flake8 <2.6.0.
@@ -12066,18 +12066,10 @@ ignoring formatting changes.")
"Make loops show a progress bar on the console by just wrapping any
iterable with @code{|tqdm(iterable)|}. Offers many options to define
design and layout.")
- (license (list license:mpl2.0 license:expat))
- (properties `((python2-variant . ,(delay python2-tqdm))))))
+ (license (list license:mpl2.0 license:expat))))
(define-public python2-tqdm
- (let ((tqdm (package-with-python2
- (strip-python2-variant python-tqdm))))
- (package
- (inherit tqdm)
- (native-inputs
- ;; FIXME: This should be propagated from python2-flake8 instead.
- `(("python2-enum34" ,python2-enum34)
- ,@(package-native-inputs tqdm))))))
+ (package-with-python2 python-tqdm))
(define-public python-pkginfo
(package
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8190b0ffc1..549380cda1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -541,7 +541,7 @@ libebml is a C++ library to read and write EBML files.")
(define-public libva
(package
(name "libva")
- (version "2.0.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
@@ -553,7 +553,7 @@ libebml is a C++ library to read and write EBML files.")
(string-append "https://www.freedesktop.org/software/vaapi/releases/"
"libva/libva-" version "/libva-" version ".tar.bz2")))
(sha256
- (base32 "0cz5i62jnibmnx0i80i9yipq39v16qr6fw461f6hvrh9lbwh21mv"))))
+ (base32 "03sb1b3fxw8myf9kz6rxw5f3v1p0vfmk34779qx0q8fk24x9bypk"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4876918b53..04cebcff73 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3506,15 +3506,18 @@ applications.")
(define-public perl-uri
(package
(name "perl-uri")
- (version "1.71")
+ (version "1.73")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"URI-" version ".tar.gz"))
(sha256
(base32
- "05a1ck1bhvqkkk690xhsxf7276dnagk96qkh2jy4prrrgw6wm3lw"))))
+ "04z4xwiryrbxxi48bwbkgq9q9pwfgqry3wp0ramcrwv3dx5ap9yc"))))
(build-system perl-build-system)
+ (native-inputs
+ ;; For tests.
+ `(("perl-test-needs" ,perl-test-needs)))
(license l:perl-license)
(synopsis "Perl Uniform Resource Identifiers (absolute and relative)")
(description
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a3630b3cb9..444c3ea39b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -319,7 +319,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.89")
+ (version "2.4.90")
(source
(origin
(method url-fetch)
@@ -329,7 +329,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "0bm06vqqjbb06mlz2f2h4man0xp0dz928pyycs8q1d5vma19g7v2"))
+ "12xnbmqaysppkcb6zs9ih3l8m1cbk38ch0wrmn9c38ms3n7yqdyv"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a7099b4516..4de93d2161 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3821,7 +3821,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.22")
+ (version "2.23.1")
(source
(origin
(method url-fetch)
@@ -3831,7 +3831,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "1garmbyfjp0han04l2l90zzwlfbdgdxl6r1qnic36i5wkycckbny"))))
+ "1wq27cs1c9y7d1d7zp5yhq29paj9smajdb68lyvm28d2zq2vqjra"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)